comparison net-proxy/squid/squid-3.1.4.ebuild @ 226:d9365eab74f0

bump squid to 3.1.4
author holger
date Sat, 12 Jun 2010 15:11:01 +0200
parents net-proxy/squid/squid-3.1.3.ebuild@9daedfc6caf0
children
comparison
equal deleted inserted replaced
225:d55eaf887034 226:d9365eab74f0
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/squid-3.1.0.15_beta-r1.ebuild,v 1.1 2009/11/29 08:53:09 mrness Exp $
4
5 EAPI="2"
6
7 inherit eutils pam toolchain-funcs
8
9 DESCRIPTION="A full-featured web proxy cache"
10 HOMEPAGE="http://www.squid-cache.org/"
11 SRC_URI="http://www.squid-cache.org/Versions/v3/3.1/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
16 IUSE="caps ipv6 pam ldap samba sasl kerberos nis radius ssl snmp selinux logrotate test \
17 ecap icap-client \
18 mysql postgres sqlite \
19 zero-penalty-hit \
20 pf-transparent ipf-transparent kqueue \
21 elibc_uclibc kernel_linux +epoll"
22 RESTRICT=test
23
24 COMMON_DEPEND="caps? ( >=sys-libs/libcap-2.16 )
25 pam? ( virtual/pam )
26 ldap? ( net-nds/openldap )
27 kerberos? ( || ( app-crypt/mit-krb5 app-crypt/heimdal ) )
28 ssl? ( dev-libs/openssl )
29 sasl? ( dev-libs/cyrus-sasl )
30 ecap? ( net-libs/libecap )
31 selinux? ( sec-policy/selinux-squid )
32 !x86-fbsd? ( logrotate? ( app-admin/logrotate ) )
33 >=sys-libs/db-4
34 dev-lang/perl"
35 DEPEND="${COMMON_DEPEND}
36 sys-devel/automake
37 sys-devel/autoconf
38 sys-devel/libtool
39 test? ( dev-util/cppunit )"
40 RDEPEND="${COMMON_DEPEND}
41 samba? ( net-fs/samba )
42 mysql? ( dev-perl/DBD-mysql )
43 postgres? ( dev-perl/DBD-Pg )
44 sqlite? ( dev-perl/DBD-SQLite )"
45
46 # S="${WORKDIR}/${P}"
47
48 pkg_setup() {
49 if grep -qs '^[[:space:]]*cache_dir[[:space:]]\+coss' "${ROOT}"etc/squid/squid.conf; then
50 eerror "coss store IO has been disabled by upstream due to stability issues!"
51 eerror "If you want to install this version, switch the store type to something else"
52 eerror "before attempting to install this version again."
53
54 die "/etc/squid/squid.conf: cache_dir use a disabled store type"
55 fi
56
57 enewgroup squid 31
58 enewuser squid 31 -1 /var/cache/squid squid
59 }
60
61 src_prepare() {
62 epatch "${FILESDIR}"/${P}-gentoo.patch
63 epatch "${FILESDIR}"/${PN}-3.1.1-qafixes.patch
64 epatch "${FILESDIR}"/${PN}-3.1.1-libmd5.patch
65
66 # eautoreconf breaks lib/libLtdl/libtool script
67 ./bootstrap.sh || die "autoreconf failed"
68 }
69
70 src_configure() {
71 local myconf=""
72
73 local basic_modules="getpwnam,NCSA,MSNT"
74 use samba && basic_modules="SMB,multi-domain-NTLM,${basic_modules}"
75 use ldap && basic_modules="LDAP,${basic_modules}"
76 use pam && basic_modules="PAM,${basic_modules}"
77 use sasl && basic_modules="SASL,${basic_modules}"
78 use nis && ! use elibc_uclibc && basic_modules="YP,${basic_modules}"
79 use radius && basic_modules="squid_radius_auth,${basic_modules}"
80 if use mysql || use postgres || use sqlite ; then
81 basic_modules="DB,${basic_modules}"
82 fi
83
84 local digest_modules="password"
85 use ldap && digest_modules="ldap,${digest_modules}"
86
87 local ext_helpers="ip_user,session,unix_group"
88 use samba && ext_helpers="wbinfo_group,${ext_helpers}"
89 use ldap && ext_helpers="ldap_group,${ext_helpers}"
90
91 local ntlm_helpers="fakeauth"
92 use samba && ntlm_helpers="smb_lm,${ntlm_helpers}"
93
94 local negotiate_helpers=
95 if use kerberos; then
96 negotiate_helpers="squid_kerb_auth"
97 has_version app-crypt/mit-krb5 \
98 && myconf="--enable-mit --disable-heimdal" \
99 || myconf="--disable-mit --enable-heimdal"
100 fi
101
102 # coss support has been disabled
103 # If it is re-enabled again, make sure you don't enable it for elibc_uclibc (#61175)
104 myconf="${myconf} --enable-storeio=ufs,diskd,aufs"
105
106 if use kernel_linux; then
107 myconf="${myconf} --enable-linux-netfilter
108 $(use_enable epoll)"
109 elif use kernel_FreeBSD || use kernel_OpenBSD || use kernel_NetBSD ; then
110 myconf="${myconf} $(use_enable kqueue)"
111 if use pf-transparent; then
112 myconf="${myconf} --enable-pf-transparent"
113 elif use ipf-transparent; then
114 myconf="${myconf} --enable-ipf-transparent"
115 fi
116 fi
117
118 export CC=$(tc-getCC)
119
120 econf \
121 --sysconfdir=/etc/squid \
122 --libexecdir=/usr/libexec/squid \
123 --localstatedir=/var \
124 --with-pidfile=/var/run/squid.pid \
125 --datadir=/usr/share/squid \
126 --with-logdir=/var/log/squid \
127 --with-default-user=squid \
128 --enable-auth="basic,digest,negotiate,ntlm" \
129 --enable-removal-policies="lru,heap" \
130 --enable-digest-auth-helpers="${digest_modules}" \
131 --enable-basic-auth-helpers="${basic_modules}" \
132 --enable-external-acl-helpers="${ext_helpers}" \
133 --enable-ntlm-auth-helpers="${ntlm_helpers}" \
134 --enable-negotiate-auth-helpers="${negotiate_helpers}" \
135 --enable-useragent-log \
136 --enable-cache-digests \
137 --enable-delay-pools \
138 --enable-referer-log \
139 --enable-arp-acl \
140 --with-large-files \
141 --with-filedescriptors=8192 \
142 --disable-strict-error-checking \
143 $(use_enable caps) \
144 $(use_enable ipv6) \
145 $(use_enable snmp) \
146 $(use_enable ssl) \
147 $(use_enable icap-client) \
148 $(use_enable ecap) \
149 $(use_enable zero-penalty-hit zph-qos) \
150 ${myconf} || die "econf failed"
151 }
152
153 src_install() {
154 emake DESTDIR="${D}" install || die "emake install failed"
155
156 # need suid root for looking into /etc/shadow
157 fowners root:squid /usr/libexec/squid/ncsa_auth
158 fowners root:squid /usr/libexec/squid/pam_auth
159 fperms 4750 /usr/libexec/squid/ncsa_auth
160 fperms 4750 /usr/libexec/squid/pam_auth
161
162 # some cleanups
163 rm -f "${D}"/usr/bin/Run*
164
165 dodoc CONTRIBUTORS CREDITS ChangeLog QUICKSTART SPONSORS doc/*.txt \
166 helpers/ntlm_auth/no_check/README.no_check_ntlm_auth
167 newdoc helpers/basic_auth/SMB/README README.auth_smb
168 dohtml helpers/basic_auth/MSNT/README.html RELEASENOTES.html
169 newdoc helpers/basic_auth/LDAP/README README.auth_ldap
170 doman helpers/basic_auth/LDAP/*.8
171 dodoc helpers/basic_auth/SASL/squid_sasl_auth*
172
173 newpamd "${FILESDIR}/squid.pam" squid
174 newconfd "${FILESDIR}/squid.confd" squid
175 if use logrotate; then
176 newinitd "${FILESDIR}/squid.initd-logrotate" squid
177 insinto /etc/logrotate.d
178 newins "${FILESDIR}/squid.logrotate" squid
179 else
180 newinitd "${FILESDIR}/squid.initd" squid
181 exeinto /etc/cron.weekly
182 newexe "${FILESDIR}/squid.cron" squid.cron
183 fi
184
185 rm -rf "${D}"/var
186 diropts -m0755 -o squid -g squid
187 keepdir /var/cache/squid /var/log/squid
188 }
189
190 pkg_postinst() {
191 echo
192 ewarn "Squid authentication helpers have been installed suid root."
193 ewarn "This allows shadow based authentication (see bug #52977 for more)."
194 echo
195 ewarn "Be careful what type of cache_dir you select!"
196 ewarn " 'diskd' is optimized for high levels of traffic, but it might seem slow"
197 ewarn "when there isn't sufficient traffic to keep squid reasonably busy."
198 ewarn " If your traffic level is low to moderate, use 'aufs' or 'ufs'."
199 echo
200 ewarn "Squid can be configured to run in transparent mode like this:"
201 ewarn " ${HILITE}http_port internal-addr:3128 transparent${NORMAL}"
202 if use zero-penalty-hit; then
203 echo
204 ewarn "In order for zph_preserve_miss_tos to work, you will have to alter your kernel"
205 ewarn "with the patch that can be found on http://zph.bratcheda.org site."
206 fi
207 }