Mercurial > hg > portage
comparison net-fs/davfs2/davfs2-1.5.2.ebuild @ 376:da8488c002f2
add an ebuild for davfs2 v1.5.2
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 28 Jan 2015 16:01:59 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
375:d130eab1967f | 376:da8488c002f2 |
---|---|
1 # Copyright 1999-2014 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-1.4.7.ebuild,v 1.7 2014/08/10 20:54:46 slyfox Exp $ | |
4 | |
5 EAPI=4 | |
6 | |
7 inherit autotools eutils linux-mod user | |
8 | |
9 DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource" | |
10 HOMEPAGE="http://savannah.nongnu.org/projects/davfs2" | |
11 SRC_URI="http://mirror.lihnidos.org/GNU/savannah/davfs2/${P}.tar.gz" | |
12 | |
13 LICENSE="GPL-2" | |
14 SLOT="0" | |
15 KEYWORDS="amd64 ppc x86" | |
16 IUSE="" | |
17 RESTRICT="test" | |
18 | |
19 DEPEND="dev-libs/libxml2 | |
20 net-libs/neon | |
21 sys-libs/zlib" | |
22 RDEPEND="${DEPEND}" | |
23 | |
24 pkg_setup() { | |
25 enewgroup davfs2 | |
26 } | |
27 | |
28 src_prepare() { | |
29 sed -e "s/^NE_REQUIRE_VERSIONS.*29/& 30/" -i configure.ac | |
30 eautoreconf | |
31 } | |
32 | |
33 src_configure() { | |
34 econf dav_user=nobody --enable-largefile --docdir=/usr/share/doc/${P} | |
35 } | |
36 | |
37 src_compile() { | |
38 emake | |
39 } | |
40 | |
41 src_install() { | |
42 emake DESTDIR="${D}" install | |
43 # dodoc AUTHORS BUGS ChangeLog FAQ NEWS README README.translators THANKS TODO | |
44 | |
45 dodir /var/run/mount.davfs | |
46 keepdir /var/run/mount.davfs | |
47 fowners root:davfs2 /var/run/mount.davfs | |
48 fperms 1774 /var/run/mount.davfs | |
49 | |
50 } | |
51 | |
52 pkg_postinst() { | |
53 elog | |
54 elog "Quick setup:" | |
55 elog " (as root)" | |
56 elog " # gpasswd -a \${your_user} davfs2" | |
57 elog " # echo 'http://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab" | |
58 elog " (as user)" | |
59 elog " # mkdir -p ~/dav" | |
60 elog " \$ mount ~/dav" | |
61 elog | |
62 } |