comparison dev-util/mercurial/mercurial-1.0.ebuild @ 1:dab1199d9829

hg 1.0 :-)
author holger@hoho.dyndns.org
date Tue, 25 Mar 2008 16:58:48 +0100
parents
children
comparison
equal deleted inserted replaced
0:7985ba427c7d 1:dab1199d9829
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-0.9.5-r1.ebuild,v 1.5 2008/01/21 09:36:03 nelchael Exp $
4
5 inherit bash-completion distutils elisp-common flag-o-matic eutils
6
7 DESCRIPTION="Scalable distributed SCM"
8 HOMEPAGE="http://www.selenic.com/mercurial/"
9 SRC_URI="http://www.selenic.com/mercurial/release/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
14 IUSE="bugzilla cvs darcs emacs git gpg subversion test zsh-completion"
15
16 CDEPEND=">=dev-lang/python-2.3"
17 RDEPEND="${CDEPEND}
18 bugzilla? ( dev-python/mysql-python )
19 cvs? ( dev-util/cvs )
20 darcs? ( || ( dev-python/celementtree dev-python/elementtree ) )
21 git? ( dev-util/git )
22 gpg? ( app-crypt/gnupg )
23 subversion? ( dev-util/subversion )
24 zsh-completion? ( app-shells/zsh )"
25 DEPEND="${CDEPEND}
26 emacs? ( virtual/emacs )
27 test? ( app-arch/unzip )"
28
29 PYTHON_MODNAME="${PN} hgext"
30 SITEFILE="70${PN}-gentoo.el"
31
32 src_unpack() {
33 distutils_src_unpack
34 }
35
36 src_compile() {
37 filter-flags -ftracer -ftree-vectorize
38
39 distutils_src_compile
40
41 if use emacs; then
42 cd "${S}"/contrib
43 elisp-compile mercurial.el || die "elisp-compile failed!"
44 fi
45
46 rm -rf contrib/{win32,macosx}
47 }
48
49 src_install() {
50 distutils_src_install
51
52 dobashcompletion contrib/bash_completion ${PN}
53
54 if use zsh-completion ; then
55 insinto /usr/share/zsh/site-functions
56 newins contrib/zsh_completion _hg
57 fi
58
59 dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
60 cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
61 rm -f contrib/bash_completion
62 cp -r contrib "${D}"/usr/share/doc/${PF}/
63 doman doc/*.?
64
65 if use emacs; then
66 elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
67 elisp-site-file-install "${FILESDIR}"/${SITEFILE}
68 fi
69 }
70
71 pkg_postinst() {
72 distutils_pkg_postinst
73 use emacs && elisp-site-regen
74 bash-completion_pkg_postinst
75 }
76
77 pkg_postrm() {
78 distutils_pkg_postrm
79 use emacs && elisp-site-regen
80 }