Mercurial > hg > portage
comparison app-admin/jailkit/jailkit-2.13.ebuild @ 337:e9bee0cb5018
Automated merge with http://hoho.dyndns.org/hg/portage
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 11 Apr 2012 02:37:47 +0200 |
parents | f379bcbcfffa |
children |
comparison
equal
deleted
inserted
replaced
336:969a66f2de7d | 337:e9bee0cb5018 |
---|---|
1 # Copyright 1999-2010 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 EAPI="2" | |
6 | |
7 inherit autotools eutils | |
8 | |
9 DESCRIPTION="Allows you to easily put programs and users in a chrooted environment" | |
10 HOMEPAGE="http://olivier.sessink.nl/jailkit/" | |
11 SRC_URI="http://olivier.sessink.nl/${PN}/${P}.tar.bz2" | |
12 | |
13 LICENSE="BSD" | |
14 SLOT="0" | |
15 KEYWORDS="~x86" | |
16 IUSE="" | |
17 | |
18 src_prepare() { | |
19 epatch \ | |
20 "${FILESDIR}/${P}-ldflags.patch" \ | |
21 "${FILESDIR}/${P}-pyc.patch" \ | |
22 "${FILESDIR}/${P}-noshells.patch" | |
23 eautoreconf | |
24 } | |
25 | |
26 src_install() { | |
27 emake DESTDIR="${D}" install || die "emake install failed" | |
28 doinitd "${FILESDIR}/jailkit" || die "doinit install failed" | |
29 } | |
30 | |
31 pkg_postinst() { | |
32 ebegin "Updating /etc/shells" | |
33 { grep -v "^/usr/sbin/jk_chrootsh$" "${ROOT}"etc/shells; echo "/usr/sbin/jk_chrootsh"; } > "${T}"/shells | |
34 mv -f "${T}"/shells "${ROOT}"etc/shells | |
35 eend $? | |
36 } |