comparison net-p2p/deluge/deluge-1.3.3.ebuild @ 290:eb98558e684c

bump deluge to 1.3.3
author holger
date Sat, 23 Jul 2011 21:07:52 +0200
parents
children a6bb3a2f981a
comparison
equal deleted inserted replaced
289:001d8f3f0b6e 290:eb98558e684c
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.2.ebuild,v 1.1 2011/06/05 11:54:47 armin76 Exp $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.5"
7
8 inherit distutils flag-o-matic
9
10 DESCRIPTION="BitTorrent client with a client/server model."
11 HOMEPAGE="http://deluge-torrent.org/"
12 SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
17 IUSE="gtk libnotify webinterface"
18
19 DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
20 dev-python/setuptools"
21 RDEPEND="${DEPEND}
22 dev-python/chardet
23 dev-python/pyopenssl
24 dev-python/pyxdg
25 || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
26 >=dev-python/twisted-8.1
27 >=dev-python/twisted-web-8.1
28 gtk? (
29 dev-python/pygame
30 dev-python/pygobject
31 >=dev-python/pygtk-2.12
32 gnome-base/librsvg
33 libnotify? ( dev-python/notify-python )
34 )
35 webinterface? ( dev-python/mako )"
36
37 pkg_setup() {
38 append-ldflags $(no-as-needed)
39 python_set_active_version 2
40 python_pkg_setup
41 }
42
43 src_prepare() {
44 distutils_src_prepare
45 python_convert_shebangs -r 2 .
46 }
47
48 src_install() {
49 distutils_src_install
50 newinitd "${FILESDIR}"/deluged.init deluged
51 newconfd "${FILESDIR}"/deluged.conf deluged
52 }
53
54 pkg_postinst() {
55 distutils_pkg_postinst
56 elog
57 elog "If after upgrading it doesn't work, please remove the"
58 elog "'~/.config/deluge' directory and try again, but make a backup"
59 elog "first!"
60 elog
61 elog "To start the daemon either run 'deluged' as user"
62 elog "or modify /etc/conf.d/deluged and run"
63 elog "/etc/init.d/deluged start as root"
64 elog "You can still use deluge the old way"
65 elog
66 elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
67 elog
68 }