Mercurial > hg > portage
comparison net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild @ 61:efdeddd494e9
pull changes from holgi
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 15 Aug 2008 17:26:54 +0200 |
parents | acd741f300f7 |
children |
comparison
equal
deleted
inserted
replaced
57:4cd1ebbb3297 | 61:efdeddd494e9 |
---|---|
1 # Copyright 1999-2008 Gentoo Foundation | 1 # Copyright 1999-2008 Gentoo Foundation |
2 # Distributed under the terms of the GNU General Public License v2 | 2 # Distributed under the terms of the GNU General Public License v2 |
3 # $Header: $ | 3 # $Header: $ |
4 | 4 |
5 # NOTE: The comments in this file are for instruction and documentation. | 5 inherit eutils |
6 # They're not meant to appear with your final, production ebuild. Please | |
7 # remember to remove them before submitting or committing your ebuild. That | |
8 # doesn't mean you can't add your own comments though. | |
9 | 6 |
10 # The 'Header' on the third line should just be left alone. When your ebuild | |
11 # will be committed to cvs, the details on that line will be automatically | |
12 # generated to contain the correct data. | |
13 | |
14 # The EAPI variable tells the ebuild format in use. | |
15 # Defaults to 0 if not specified. The current PMS draft contains details on | |
16 # a proposed EAPI=0 definition but is not finalized yet. | |
17 # Eclasses will test for this variable if they need to use EAPI > 0 features. | |
18 # Ebuilds should not define EAPI > 0 unless they absolutely need to use | |
19 # features added in that version. | |
20 #EAPI=0 | |
21 | |
22 # inherit lists eclasses to inherit functions from. Almost all ebuilds should | |
23 # inherit eutils, as a large amount of important functionality has been | |
24 # moved there. For example, the $(get_libdir) mentioned below wont work | |
25 # without the following line: | |
26 inherit eutils | |
27 # A well-used example of an eclass function that needs eutils is epatch. If | |
28 # your source needs patches applied, it's suggested to put your patch in the | |
29 # 'files' directory and use: | |
30 # | |
31 # epatch ${FILESDIR}/patch-name-here | |
32 # | |
33 # eclasses tend to list descriptions of how to use their functions properly. | |
34 # take a look at /usr/portage/eclasses/ for more examples. | |
35 | |
36 # Short one-line description of this package. | |
37 DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang." | 7 DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang." |
38 | 8 HOMEPAGE="http://www.rabbitmq.com/" |
39 # Homepage, not used by Portage directly but handy for developer reference | |
40 HOMEPAGE="http://www.rabbitmq.com/" | |
41 | |
42 # Point to any required sources; these will be automatically downloaded by | |
43 # Portage. | |
44 SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz" | 9 SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz" |
45 | |
46 # License of the package. This must match the name of file(s) in | |
47 # /usr/portage/licenses/. For complex license combination see the developer | |
48 # docs on gentoo.org for details. | |
49 LICENSE="MPL" | 10 LICENSE="MPL" |
50 | 11 SLOT="0" |
51 # The SLOT variable is used to tell Portage if it's OK to keep multiple | 12 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86" |
52 # versions of the same package installed at the same time. For example, | |
53 # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible | |
54 # with 1.2.2), it would be optimal to instruct Portage to not remove | |
55 # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this, | |
56 # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2. | |
57 # emerge clean understands SLOTs, and will keep the most recent version | |
58 # of each SLOT and remove everything else. | |
59 # Note that normal applications should use SLOT="0" if possible, since | |
60 # there should only be exactly one version installed at a time. | |
61 # DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package. | |
62 SLOT="0" | |
63 | |
64 # Using KEYWORDS, we can record masking information *inside* an ebuild | |
65 # instead of relying on an external package.mask file. Right now, you should | |
66 # set the KEYWORDS variable for every ebuild so that it contains the names of | |
67 # all the architectures with which the ebuild works. All of the official | |
68 # architectures can be found in the keywords.desc file which is in | |
69 # /usr/portage/profiles/. Usually you should just set this to "~x86". The ~ | |
70 # in front of the architecture indicates that the package is new and should be | |
71 # considered unstable until testing proves its stability. So, if you've | |
72 # confirmed that your ebuild works on x86 and ppc, you'd specify: | |
73 # KEYWORDS="~x86 ~ppc" | |
74 # Once packages go stable, the ~ prefix is removed. | |
75 # For binary packages, use -* and then list the archs the bin package | |
76 # exists for. If the package was for an x86 binary package, then | |
77 # KEYWORDS would be set like this: KEYWORDS="-* x86" | |
78 # DO NOT USE KEYWORDS="*". This is deprecated and only for backward | |
79 # compatibility reasons. | |
80 KEYWORDS="~x86" | |
81 | |
82 # Comprehensive list of any and all USE flags leveraged in the ebuild, | |
83 # with the exception of any ARCH specific flags, i.e. "ppc", "sparc", | |
84 # "x86" and "alpha". This is a required variable. If the ebuild doesn't | |
85 # use any USE flags, set to "". | |
86 IUSE="" | 13 IUSE="" |
87 | 14 |
88 # A space delimited list of portage features to restrict. man 5 ebuild | 15 # Q: is RDEPEND-only sufficient for a binary package, since we don't compile? |
89 # for details. Usually not needed. | |
90 #RESTRICT="strip" | |
91 | |
92 # Build-time dependencies, such as | |
93 # ssl? ( >=dev-libs/openssl-0.9.6b ) | |
94 # >=dev-lang/perl-5.6.1-r1 | |
95 # It is advisable to use the >= syntax show above, to reflect what you | |
96 # had installed on your system when you tested the package. Then | |
97 # other users hopefully won't be caught without the right version of | |
98 # a dependency. | |
99 DEPEND="dev-lang/erlang" | 16 DEPEND="dev-lang/erlang" |
100 | |
101 # Run-time dependencies. Must be defined to whatever this depends on to run. | |
102 # The below is valid if the same run-time depends are required to compile. | |
103 RDEPEND="${DEPEND}" | 17 RDEPEND="${DEPEND}" |
104 | 18 |
105 # Source directory; the dir where the sources can be found (automatically | 19 # grr: the packaged directory contains an underscore |
106 # unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P} | 20 S="${WORKDIR}/rabbitmq_server-${PV}" |
107 # If you don't need to change it, leave the S= line out of the ebuild | |
108 # to keep it tidy. | |
109 #S="${WORKDIR}/${P}" | |
110 | |
111 src_compile() { | |
112 # Most open-source packages use GNU autoconf for configuration. | |
113 # The quickest (and preferred) way of running configure is: | |
114 econf || die "econf failed" | |
115 # | |
116 # You could use something similar to the following lines to | |
117 # configure your package before compilation. The "|| die" portion | |
118 # at the end will stop the build process if the command fails. | |
119 # You should use this at the end of critical commands in the build | |
120 # process. (Hint: Most commands are critical, that is, the build | |
121 # process should abort if they aren't successful.) | |
122 #./configure \ | |
123 # --host=${CHOST} \ | |
124 # --prefix=/usr \ | |
125 # --infodir=/usr/share/info \ | |
126 # --mandir=/usr/share/man || die "./configure failed" | |
127 # Note the use of --infodir and --mandir, above. This is to make | |
128 # this package FHS 2.2-compliant. For more information, see | |
129 # http://www.pathname.com/fhs/ | |
130 | |
131 # emake (previously known as pmake) is a script that calls the | |
132 # standard GNU make with parallel building options for speedier | |
133 # builds (especially on SMP systems). Try emake first. It might | |
134 # not work for some packages, because some makefiles have bugs | |
135 # related to parallelism, in these cases, use emake -j1 to limit | |
136 # make to a single process. The -j1 is a visual clue to others | |
137 # that the makefiles have bugs that have been worked around. | |
138 emake || die "emake failed" | |
139 } | |
140 | 21 |
141 src_install() { | 22 src_install() { |
142 # You must *personally verify* that this trick doesn't install | 23 # the local erlang module directory |
143 # anything outside of DESTDIR; do this by reading and | 24 local targetdir="/usr/$(get_libdir)/erlang/lib/${P}" |
144 # understanding the install part of the Makefiles. | |
145 # This is the preferred way to install. | |
146 emake DESTDIR="${D}" install || die "emake install failed" | |
147 | 25 |
148 # When you hit a failure with emake, do not just use make. It is | 26 # scripts |
149 # better to fix the Makefiles to allow proper parallelization. | 27 dosbin sbin/* |
150 # If you fail with that, use "emake -j1", it's still better than make. | |
151 | 28 |
152 # For Makefiles that don't make proper use of DESTDIR, setting | 29 # erlang module |
153 # prefix is often an alternative. However if you do this, then | 30 dodir "${targetdir}" |
154 # you also need to specify mandir and infodir, since they were | 31 cp -dpR ebin include src "${D}/${targetdir}" |
155 # passed to ./configure as absolute paths (overriding the prefix | |
156 # setting). | |
157 #emake \ | |
158 # prefix="${D}"/usr \ | |
159 # mandir="${D}"/usr/share/man \ | |
160 # infodir="${D}"/usr/share/info \ | |
161 # libdir="${D}"/usr/$(get_libdir) \ | |
162 # install || die "emake install failed" | |
163 # Again, verify the Makefiles! We don't want anything falling | |
164 # outside of ${D}. | |
165 | 32 |
166 # The portage shortcut to the above command is simply: | 33 # docs |
167 # | 34 dodoc INSTALL LICENSE LICENSE-MPL-RabbitMQ |
168 #einstall || die "einstall failed" | 35 |
36 # TODO: | |
37 # config to set env vars as per INSTALL? | |
38 # set LOGDIR to /var/log/rabbitmq.log | |
39 # run as different user? | |
169 } | 40 } |