diff net-misc/zmq/zmq-1.0.0.ebuild @ 149:0f0eee037856

zeromq-1.0.0 is final
author holger
date Mon, 20 Jul 2009 00:12:50 +0200
parents net-misc/zmq/zmq-0.6.1.ebuild@e3983612de33
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/zmq/zmq-1.0.0.ebuild	Mon Jul 20 00:12:50 2009 +0200
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="ZeroMQ is a brokerless messaging kernel with extremely high performance."
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="http://www.zeromq.org/local--files/area:download/${P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="amqp c examples java profile python ruby"
+#DEPEND=""
+#RDEPEND="${DEPEND}"
+
+src_compile() {
+
+# TODO:
+#  --with-perf             build performance tests [default=no]
+#  --with-butterfly        build butterfly example [default=no]
+#  --with-camera           build camera example [default=no]
+#  --with-exchange         build exchange example [default=no]
+#  --with-chat             build chatroom example [default=no]
+#  --with-ruby             build Ruby language binding [default=no]
+
+	econf \
+    $(use_with amqp) \
+    $(use_with c) \
+    $(use_with java) \
+    $(use_with python)
+
+	emake || die "emake failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+}