diff dev-lang/dart/dart-1.20.1.ebuild @ 427:18fecfcfbe40

update to dart 1.20.1, remove older dart ebuilds
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sun, 06 Nov 2016 04:35:09 +0100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-lang/dart/dart-1.20.1.ebuild	Sun Nov 06 04:35:09 2016 +0100
@@ -0,0 +1,31 @@
+
+EAPI=6
+DESCRIPTION="Dart is an application programming language that’s easy to learn, easy to scale, and deployable everywhere."
+HOMEPAGE="https://www.dartlang.org"
+SRC_URI="https://storage.googleapis.com/dart-archive/channels/stable/release/${PV}/sdk/dartsdk-linux-x64-release.zip -> ${P}.zip"
+SLOT="0"
+KEYWORDS="amd64"
+S=${WORKDIR}/dart-sdk
+
+RDEPEND="sys-libs/glibc"
+
+src_compile() { :; }
+
+src_install() {
+	local MY_DEST=/opt/dart-${PV}
+
+	insinto ${MY_DEST}
+	doins -r *
+
+	for x in ${D}${MY_DEST}/bin/*; do
+		if [ -f $x ]; then
+			# fperms implicitly adds ${D} which we had to add for listing above
+			chmod +x $x
+		fi
+	done
+	chmod +x ${D}${MY_DEST}/lib/analysis_server/tool/spec/generate_files
+	chmod +x ${D}${MY_DEST}/lib/analyzer/tool/generate_files
+
+	dosym ${MY_DEST}/bin/dart /opt/bin/dart
+	dosym ${MY_DEST}/bin/pub /opt/bin/pub
+}