diff net-im/psi-plus/psi-plus-0.16.452.ebuild @ 394:323ff9881d83

fix the compilation for newer psi snapshots ...
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 11 Jun 2015 16:18:32 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/psi-plus/psi-plus-0.16.452.ebuild	Thu Jun 11 16:18:32 2015 +0200
@@ -0,0 +1,137 @@
+
+EAPI=5
+
+inherit eutils l10n multilib gnome2-utils qt4-r2
+
+DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
+HOMEPAGE="https://github.com/psi-plus/psi-plus-snapshots/"
+SRC_URI="https://github.com/psi-plus/psi-plus-snapshots/archive/${PV}.tar.gz"
+
+S="${WORKDIR}/psi-plus-snapshots-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding"
+#RESTRICT="test"
+
+RDEPEND="app-arch/unzip
+	>=dev-qt/qtgui-4.7:4
+	>=app-crypt/qca-2.0.2:2[qt4(+)]
+	x11-libs/libX11
+	dbus? ( >=dev-qt/qtdbus-4.7:4 )
+	spell? ( >=app-text/enchant-1.3.0 )
+	xscreensaver? ( x11-libs/libXScrnSaver )
+	whiteboarding? ( dev-qt/qtsvg:4 )
+	|| ( >=sys-libs/zlib-1.2.5.1-r2[minizip] <sys-libs/zlib-1.2.5.1-r1 )"
+
+DEPEND="${RDEPEND}
+	sys-devel/qconf
+	doc? ( app-doc/doxygen )"
+
+PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
+	jingle? ( net-im/psimedia
+		app-crypt/qca:2[openssl] )
+	ssl? ( app-crypt/qca:2[openssl] )
+	otrplugin? ( net-libs/libotr app-text/htmltidy )"
+
+src_prepare() {
+	epatch "${FILESDIR}/qmake.patch"
+	epatch_user
+}
+
+src_configure() {
+	# unable to use econf because of non-standard configure script
+	local confcmd="./configure
+		--prefix=/usr
+		--datadir=/usr/share
+		--libdir=/usr/lib64
+		--disable-growl
+		$(use dbus || echo '--disable-qdbus')
+		$(use debug && echo '--debug')
+		$(use plugins && echo '--enable-plugins')
+		$(use spell || echo '--disable-aspell')
+		$(use spell || echo '--disable-enchant')
+		$(use xscreensaver || echo '--disable-xss')
+		$(use whiteboarding && echo '--enable-whiteboarding')"
+
+	echo ${confcmd}
+	${confcmd} || die "configure failed"
+	## Makefile is not always created...
+	#[[ ! -f Makefile ]] && die "configure failed"
+}
+
+src_compile() {
+	emake || die "emake failed"
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+	
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+	dodoc README TODO ChangeLog
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libautoreplyplugin.so
+
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libotrplugin.so
+
+		cd ../../../..
+	fi
+
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libwatcherplugin.so
+
+		cd ../../../..
+	fi
+}
+
+pkg_preinst() {
+	gnome2_icon_savelist
+}
+
+pkg_postinst() {
+	gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}