diff media-sound/exaile/exaile-0.3.1.1.ebuild @ 281:34ae6a0a3fe8

pull all the latest changes from Holgi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 01 Apr 2011 17:58:34 +0200
parents a588f50b1e1d
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-sound/exaile/exaile-0.3.1.1.ebuild	Fri Apr 01 17:58:34 2011 +0200
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/Attic/exaile-0.3.1.1.ebuild,v 1.2 2010/08/14 17:33:32 ssuominen dead $
+
+EAPI=2
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/exaile/0.3.1/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+	>=media-libs/mutagen-1.10
+	>=dev-python/pygtk-2.14
+	>=dev-python/pygobject-2.18
+	dev-python/gst-python:0.10
+	media-libs/gst-plugins-good:0.10
+	media-plugins/gst-plugins-meta:0.10
+	libnotify? ( dev-python/notify-python )
+	cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+	sys-devel/gettext )"
+
+# Required python 'mox' module missing wrt #315589
+RESTRICT="test"
+
+pkg_setup() {
+	python_set_active_version 2
+}
+
+src_prepare() {
+	sed -i \
+		-e "s:exec python:exec $(PYTHON):" \
+		exaile tools/generate-launcher || die
+}
+
+src_compile() {
+	if use nls; then
+		emake locale || die
+	fi
+}
+
+src_install() {
+	local _no_locale
+	use nls || _no_locale=_no_locale
+
+	emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+		install${_no_locale} || die
+
+	dodoc README
+
+	insinto /usr/share/exaile/data
+	doins -r data/migrations || die
+}
+
+pkg_postinst() {
+	python_need_rebuild
+	python_mod_optimize /usr/$(get_libdir)/${PN}
+	fdo-mime_desktop_database_update
+	fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+	python_mod_cleanup /usr/$(get_libdir)/${PN}
+	fdo-mime_desktop_database_update
+	fdo-mime_mime_database_update
+}