diff app-arch/pigz/pigz-2.1.5.ebuild @ 174:3b3ba42f2f0e

pigz-2.1.5 symlink bugfix & support for gzip symlink
author holger
date Sat, 14 Nov 2009 03:27:58 +0100
parents
children 9839e927aee2
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-arch/pigz/pigz-2.1.5.ebuild	Sat Nov 14 03:27:58 2009 +0100
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.1.5.ebuild,v 1.2 2009/11/02 17:58:48 vostorga Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A parallel implementation of gzip."
+HOMEPAGE="http://www.zlib.net/pigz/"
+SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"
+
+LICENSE="PIGZ"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test symlink"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+	test? ( app-arch/ncompress )"
+
+src_unpack() {
+	unpack ${A}
+	epatch "${FILESDIR}"/${P}-respect-flags.patch
+	epatch "${FILESDIR}"/${P}-decode-symlinks-to-stdout.patch
+}
+
+src_compile() {
+	tc-export CC
+	emake || die "make failed"
+}
+
+src_install() {
+	dobin ${PN} || die "Failed to install"
+	dosym /usr/bin/pigz /usr/bin/unpigz
+	dodoc README
+
+	if use symlink; then
+		dosym /usr/bin/pigz /usr/bin/gzip
+	fi
+}