diff net-misc/zmq/zmq-0.3.1.ebuild @ 80:6da0c8668e7e

add TODOs, verify that initial install works
author holger@hoho.dyndns.org
date Tue, 14 Oct 2008 04:50:48 +0200
parents 7165b0bc5268
children
line wrap: on
line diff
--- a/net-misc/zmq/zmq-0.3.1.ebuild	Mon Oct 13 19:00:52 2008 +0200
+++ b/net-misc/zmq/zmq-0.3.1.ebuild	Tue Oct 14 04:50:48 2008 +0200
@@ -10,19 +10,22 @@
 LICENSE="LGPL-3"
 SLOT="0"
 KEYWORDS="~x86"
-IUSE="c java python profile"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}.  The default value for S is ${WORKDIR}/${P}
-# If you don't need to change it, leave the S= line out of the ebuild
-# to keep it tidy.
-#S="${WORKDIR}/${P}"
+#IUSE="c examples java profile python"
+#DEPEND=""
+#RDEPEND="${DEPEND}"
 
 src_compile() {
-	econf || die "econf failed"
+
+# TODO:
+#  --with-perf             build performance tests [default=no]
+#  --with-camera           build camera example [default=no]
+#  --with-exchange         build exchange example [default=no]
+#  --with-chat             build chatroom example [default=no]
+#  --with-c                build c language binding [default=no]
+#  --with-python           build Python language binding [default=no]
+#  --with-java             build Java language binding [default=no]
+
+	econf \
 	emake || die "emake failed"
 }