diff net-misc/e1000/e1000-7.6.15.5.ebuild @ 0:7985ba427c7d

initial import from svn
author holger@wizards.de
date Sat, 22 Mar 2008 03:58:33 +0100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/e1000/e1000-7.6.15.5.ebuild	Sat Mar 22 03:58:33 2008 +0100
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
+HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+
+src_unpack() {
+    unpack ${A}
+    cd ${S}/src
+    # rem out the DEPVER line, since it would cause a sandbox violation and
+    # since it is only needed by RPM ;-)
+    sed -i "/^DEPVER :=/ d" Makefile
+}
+
+
+src_compile() {
+    check_KV
+    cd "${S}/src"
+
+    # workaround needed for some ethernet controllers to work with low end switches
+    if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+        then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+        else CFLAGS_EXTRA=""
+    fi
+
+    make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
+}
+
+
+src_install() {
+    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000"
+    doins "${S}/src/e1000.ko"
+    doman e1000.7
+    dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
+    einfo ""
+    einfo "In case you have problems when loading the module, try to run depmod -A"
+    einfo ""
+    einfo "If you experience problems with low-end switches, read"
+    einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
+    einfo ""
+}