diff sys-block/noflushd/noflushd-2.7.4.ebuild @ 0:7985ba427c7d

initial import from svn
author holger@wizards.de
date Sat, 22 Mar 2008 03:58:33 +0100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-block/noflushd/noflushd-2.7.4.ebuild	Sat Mar 22 03:58:33 2008 +0100
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/noflushd/noflushd-2.7.3.ebuild,v 1.5 2004/09/03 21:03:24 pvdabeel Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A daemon to spin down your disks and force accesses to be cached"
+HOMEPAGE="http://noflushd.sourceforge.net"
+SRC_URI="mirror://sourceforge/noflushd/${P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ppc"
+IUSE="SCSI"
+SLOT="0"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+
+	if use SCSI; then
+		ewarn "Enabling SCSI support - you do this on your own risk!"
+		epatch ${FILESDIR}/${P}-SCSI.patch
+	fi
+
+	# Replace -O[2-9] flags to keep the executable small
+	replace-flags -O[2-9] -Os
+
+	./configure --prefix=/usr \
+		--host=${CHOST} \
+		--mandir=/usr/share/man \
+		--infodir=/usr/share/info \
+		--with-docdir=/usr/share/doc/${PF} || die "configure problem"
+	emake || die "compile problem"
+}
+
+src_install () {
+	dosbin src/noflushd
+	doman man/noflushd.8
+	dodoc README NEWS
+
+	exeinto /etc/init.d ; newexe ${FILESDIR}/noflushd.rc6 noflushd
+	insinto /etc/conf.d ; newins ${FILESDIR}/noflushd.confd noflushd
+}
+
+pkg_postinst() {
+	einfo 'Run "rc-update add noflushd default" to add it to the'
+	einfo "default runlevel."
+
+	ewarn "noflushd works reliably with IDE devices only."
+	ewarn "It has possible problems with reiserfs, too."
+}
+