diff net-fs/samba/samba-3.2.6.ebuild @ 92:7f53c44576cc

fix samba shlib symlinks
author holger@hoho.dyndns.org
date Sun, 28 Dec 2008 13:25:45 +0100
parents 7c953ae90177
children f1ad2db6c510
line wrap: on
line diff
--- a/net-fs/samba/samba-3.2.6.ebuild	Sat Dec 27 15:41:47 2008 +0100
+++ b/net-fs/samba/samba-3.2.6.ebuild	Sun Dec 28 13:25:45 2008 +0100
@@ -44,16 +44,6 @@
 
 pkg_setup() {
 	confutils_use_depend_all ads ldap
-
-	ewarn "This is a pre-release. That means it is _not_ stable and only for testing."
-	ewarn "Bugs in the ebuild can be reported in our bugtracker at https://bugs.gentoo.org"
-	ewarn "Bugs in Samba should be reported at https://bugzilla.samba.org _after_"
-	ewarn "carefully checking whether it is a Samba bug. If you can't find out whether"
-	ewarn "it's in the ebuild, your setup or Samba itself, you should definitely _not_ use"
-	ewarn "this package and wait until the final release."
-	ewarn
-	ewarn "There is no python-support anymore."
-	ebeep 5
 }
 
 src_unpack() {
@@ -172,8 +162,12 @@
 
 	# bug #46389: samba doesn't create symlink anymore
 	# beaviour seems to be changed in 3.0.6, see bug #61046
-	dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so.0
-	dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so
+    dosym samba/libsmbclient.so /usr/$(get_libdir)/libsmbclient.so
+    dosym samba/libsmbclient.so.0 /usr/$(get_libdir)/libsmbclient.so.0
+    dosym samba/libtcalloc.so /usr/$(get_libdir)/libtcalloc.so
+    dosym samba/libtcalloc.so.1 /usr/$(get_libdir)/libtcalloc.so.1
+    dosym samba/libtdb.so /usr/$(get_libdir)/libtdb.so
+    dosym samba/libtdb.so.1 /usr/$(get_libdir)/libtdb.so.1
 
 	# make the smb backend symlink for cups printing support (bug #133133)
 	if use cups ; then