diff media-sound/exaile/exaile-0.3.2.0.ebuild @ 238:86a0cec24d06

Automated merge with http://hoho.dyndns.org/hg/portage
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 11 Aug 2010 04:08:09 +0200
parents da2e11c54daa
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-sound/exaile/exaile-0.3.2.0.ebuild	Wed Aug 11 04:08:09 2010 +0200
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.1.1.ebuild,v 1.1 2010/04/16 11:37:14 ssuominen Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/exaile/0.3.2/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS=""
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+	>=media-libs/mutagen-1.10
+	>=dev-python/pygtk-2.17
+	>=dev-python/pygobject-2.18
+	dev-python/gst-python:0.10
+	media-libs/gst-plugins-good:0.10
+	media-plugins/gst-plugins-meta:0.10
+	libnotify? ( dev-python/notify-python )
+	cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+	sys-devel/gettext )"
+
+# Required python 'mox' module missing wrt #315589
+RESTRICT="test"
+
+pkg_setup() {
+	python_set_active_version 2
+}
+
+src_prepare() {
+	sed -i \
+		-e "s:exec python:exec $(PYTHON):" \
+		exaile tools/generate-launcher || die
+}
+
+src_compile() {
+	if use nls; then
+		emake locale || die
+	fi
+}
+
+src_install() {
+	local _no_locale
+	use nls || _no_locale=_no_locale
+
+	emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+		install${_no_locale} || die
+
+	dodoc README
+
+	insinto /usr/share/exaile/data
+	doins -r data/migrations || die
+}
+
+pkg_postinst() {
+	python_need_rebuild
+	python_mod_optimize /usr/$(get_libdir)/${PN}
+	fdo-mime_desktop_database_update
+	fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+	python_mod_cleanup /usr/$(get_libdir)/${PN}
+	fdo-mime_desktop_database_update
+	fdo-mime_mime_database_update
+}