diff dev-db/pgpool-II/pgpool-II-2.2.2.ebuild @ 140:ae18a6f7faee

pull latest chagnes from Holgi
author Dirk Olmes <dirk.olmes@googlemail.com>
date Thu, 02 Jul 2009 14:12:03 +0200
parents b2bf9b2e80c7
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgpool-II/pgpool-II-2.2.2.ebuild	Thu Jul 02 14:12:03 2009 +0200
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="New generation connection pool server for PostgreSQL"
+HOMEPAGE="http://pgpool.projects.postgresql.org/"
+SRC_URI="http://pgfoundry.org/frs/download.php/2108/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-db/postgresql-base"
+
+src_unpack() {
+	unpack ${A}
+	S="${WORKDIR}/${PN}-2.2"
+	cd ${S}
+	sed -i -e "/^logdir/s:/tmp:/var/run:g" pgpool.conf.sample || die
+}
+
+src_compile() {
+	econf --with-pgsql=/usr/include/postgresql || die
+	emake || die
+}
+
+src_install () {
+	einstall || die
+	mv ${D}/etc/pcp.conf.sample ${D}/etc/pcp.conf
+	mv ${D}/etc/pgpool.conf.sample ${D}/etc/pgpool.conf
+	mv ${D}/etc/pool_hba.conf.sample ${D}/etc/pool_hba.conf
+	dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO
+	newinitd "${FILESDIR}/pgpool-II.init" pgpool-II || die "Inserting init.d-file failed"
+}
+