diff net-misc/gopenvpn/gopenvpn-9999-r1.ebuild @ 352:c417ea2d1eab

ebuild fro gopenvpn
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 07 Feb 2014 08:14:57 +0100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/gopenvpn/gopenvpn-9999-r1.ebuild	Fri Feb 07 08:14:57 2014 +0100
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+# project is hosted on sourceforge's git, so git-2 is needed (git is deprecated)
+inherit git-2 autotools
+
+DESCRIPTION="gopenvpn is a gtk tray icon for openvpn"
+HOMEPAGE="http://gopenvpn.sourceforge.net/"
+
+EGIT_REPO_URI="git://gopenvpn.git.sourceforge.net/gitroot/gopenvpn/gopenvpn.git"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="dev-libs/glib:2
+		x11-libs/gtk+:2
+		gnome-base/libglade
+		gnome-base/gnome-keyring
+		sys-auth/polkit"
+
+src_prepare() {
+	gettextize
+	sed -i '124s/.*/AC_CONFIG_FILES([pixmaps\/Makefile/' configure.ac
+	autoreconf -vif
+	./configure
+}