diff net-im/tootle/tootle-0.1.5.ebuild @ 461:f1cc6af6f4b8

add tootle ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 12 Jul 2018 21:06:09 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/tootle/tootle-0.1.5.ebuild	Thu Jul 12 21:06:09 2018 +0200
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson vala gnome2-utils
+
+DESCRIPTION="GTK3 client for Mastodon"
+HOMEPAGE="https://github.com/bleakgrey/tootle"
+SRC_URI="https://github.com/bleakgrey/tootle/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+	dev-libs/glib
+	dev-libs/granite
+	dev-libs/json-glib
+	net-libs/libsoup:2.4
+	x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+	vala_src_prepare
+	default
+}
+
+pkg_preinst() {
+	gnome2_gconf_savelist
+	gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+	gnome2_icon_cache_update
+	gnome2_gconf_install
+	gnome2_schemas_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}