diff dev-db/postgresql-docs/postgresql-docs-8.4.0.ebuild @ 148:fb0267e87240

new import of postgres-8.4.0
author holger
date Fri, 10 Jul 2009 18:34:34 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/postgresql-docs/postgresql-docs-8.4.0.ebuild	Fri Jul 10 18:34:34 2009 +0200
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.3.7.ebuild,v 1.4 2009/06/05 22:49:22 beandog Exp $
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# Nothing to test here per 232157
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="test"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+src_compile() {
+	:
+}
+
+src_install() {
+	dodir /usr/share/doc/${PF}/html
+	tar -zxf "${S}/doc/postgres.tar.gz" -C "${D}/usr/share/doc/${PF}/html"
+	cd "${S}/doc"
+	dodoc TODO
+	docinto FAQ_html
+	dodoc src/FAQ/*
+
+	dodir /etc/eselect/postgresql/slots/${SLOT}
+	{
+		echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\""
+	} >"${D}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}