diff net-misc/zmq/zmq-0.6.ebuild @ 132:fdf0c737a687

bump zeromq to 0.6
author holger
date Fri, 22 May 2009 23:45:17 +0200
parents net-misc/zmq/zmq-0.4.ebuild@49f1b15fc148
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/zmq/zmq-0.6.ebuild	Fri May 22 23:45:17 2009 +0200
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="ZeroMQ is a brokerless messaging kernel with extremely high performance."
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="http://www.zeromq.org/local--files/area:download/${P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+#IUSE="c examples java profile python"
+#DEPEND=""
+#RDEPEND="${DEPEND}"
+
+src_compile() {
+
+# TODO:
+#  --with-perf             build performance tests [default=no]
+#  --with-camera           build camera example [default=no]
+#  --with-exchange         build exchange example [default=no]
+#  --with-chat             build chatroom example [default=no]
+#  --with-c                build c language binding [default=no]
+#  --with-python           build Python language binding [default=no]
+#  --with-java             build Java language binding [default=no]
+
+	econf \
+	emake || die "emake failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "emake install failed"
+}