Mercurial > hg > portage
view dev-python/python-sipsimple/python-sipsimple-3.1.0.ebuild @ 490:086a16570180
updated ebuild for vscodium
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Sun, 20 Oct 2019 02:51:30 +0200 |
parents | 8b06995f9f2a |
children |
line wrap: on
line source
# Copyright 1999-2015 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Id$ EAPI="5" PYTHON_COMPAT=( python2_7 ) inherit distutils-r1 DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit" HOMEPAGE="http://sipsimpleclient.org" SRC_URI="https://github.com/AGProjects/python-sipsimple/archive/release-${PV}.tar.gz -> ${P}.tar.gz" LICENSE="GPL-3" SLOT="0" IUSE="libressl" KEYWORDS="~amd64 ~x86" CDEPEND=" dev-db/sqlite:3 !libressl? ( dev-libs/openssl:0[-bindist] ) libressl? ( dev-libs/libressl ) dev-python/python-application[${PYTHON_USEDEP}] media-libs/alsa-lib media-libs/libv4l media-libs/libvpx sys-apps/util-linux virtual/ffmpeg media-libs/openh264 " RDEPEND="${CDEPEND} virtual/python-dnspython[${PYTHON_USEDEP}] dev-python/python-cjson[${PYTHON_USEDEP}] dev-python/python-dateutil[${PYTHON_USEDEP}] dev-python/python-eventlib[${PYTHON_USEDEP}] dev-python/greenlet[${PYTHON_USEDEP}] dev-python/python-gnutls[${PYTHON_USEDEP}] dev-python/lxml[${PYTHON_USEDEP}] dev-python/python-msrplib[${PYTHON_USEDEP}] dev-python/python-xcaplib[${PYTHON_USEDEP}] dev-python/twisted-core[${PYTHON_USEDEP}] dev-python/zope-interface[${PYTHON_USEDEP}] dev-python/potr[${PYTHON_USEDEP}] " DEPEND="${CDEPEND} dev-python/cython[${PYTHON_USEDEP}] virtual/pkgconfig " S="${WORKDIR}/${PN}-release-${PV}" src_prepare() { chmod +x ${S}/deps/pjsip/configure chmod +x ${S}/deps/pjsip/aconfigure epatch "${FILESDIR}/aconfigure.openh264.patch" epatch "${FILESDIR}/setup_pjsip.openh264.patch" }