Mercurial > hg > portage
view sys-fs/ntfs3g/ntfs3g-1.5130.ebuild @ 149:0f0eee037856
zeromq-1.0.0 is final
author | holger |
---|---|
date | Mon, 20 Jul 2009 00:12:50 +0200 |
parents | 7360f9380ed4 |
children |
line wrap: on
line source
# Copyright 1999-2008 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.5012.ebuild,v 1.1 2008/10/23 14:23:59 chutzpah Exp $ MY_PN="${PN/3g/-3g}" MY_P="${MY_PN}-${PV}" DESCRIPTION="Open source read-write NTFS driver that runs under FUSE" HOMEPAGE="http://www.ntfs-3g.org" SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz" LICENSE="GPL-2" SLOT="0" KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86" IUSE="debug hal suid" RDEPEND="hal? ( sys-apps/hal )" DEPEND="${RDEPEND}" S="${WORKDIR}/${MY_P}" src_compile() { econf \ --docdir="/usr/share/doc/${PF}" \ --enable-ldscript \ --disable-ldconfig \ $(use_enable debug) emake || die "emake failed" } src_install() { emake DESTDIR="${D}" install || die "install failed" prepalldocs dodoc AUTHORS ChangeLog CREDITS use suid && fperms u+s "/bin/${MY_PN}" if use hal; then insinto /etc/hal/fdi/policy/ doins "${FILESDIR}/10-ntfs3g.fdi" fi } pkg_postinst() { if use suid; then ewarn ewarn "You have chosen to install ${PN} with the binary setuid root. This" ewarn "means that if there any undetected vulnerabilities in the binary," ewarn "then local users may be able to gain root access on your machine." ewarn fi }