view dev-db/pgpool-II/pgpool-II-2.2.3.ebuild @ 155:143d9700af31

ntfs3g is up to date in portage
author holger
date Sat, 22 Aug 2009 01:10:14 +0200
parents c494760eb51c
children
line wrap: on
line source

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="New generation connection pool server for PostgreSQL"
HOMEPAGE="http://pgpool.projects.postgresql.org/"
SRC_URI="http://pgfoundry.org/frs/download.php/2108/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""

DEPEND="virtual/postgresql-base"

src_unpack() {
        unpack ${A}
        S="${WORKDIR}/${PN}-2.2"
        cd ${S}
        sed -i -e "/^logdir/s:/tmp:/var/run:g" pgpool.conf.sample || die
}

src_compile() {
        econf --with-pgsql=/usr/include/postgresql || die
        emake || die
}

src_install () {
        einstall || die
        mv ${D}/etc/pcp.conf.sample ${D}/etc/pcp.conf
        mv ${D}/etc/pgpool.conf.sample ${D}/etc/pgpool.conf
        mv ${D}/etc/pool_hba.conf.sample ${D}/etc/pool_hba.conf
        dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO
        newinitd "${FILESDIR}/pgpool-II.init" pgpool-II || die "Inserting init.d-file failed"
}