view dev-python/python-msrplib/python-msrplib-0.19.1.ebuild @ 454:175c21f9bfe2

plugins go to a different location now
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 14 Dec 2017 11:12:12 +0100
parents 7e560a7c788b
children
line wrap: on
line source

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1

inherit distutils-r1

DESCRIPTION="Client library for MSRP protocol and its relay extension"
HOMEPAGE="http://sipsimpleclient.org"
SRC_URI="https://github.com/AGProjects/${PN}/archive/release-${PV}.tar.gz"
S=${WORKDIR}/${PN}-release-${PV}

LICENSE="LGPL-2+"
SLOT="0"
IUSE=""

KEYWORDS="~amd64 ~x86"

RDEPEND="
	dev-python/python-application[${PYTHON_USEDEP}]
	dev-python/python-eventlib[${PYTHON_USEDEP}]
	dev-python/python-gnutls[${PYTHON_USEDEP}]
	dev-python/twisted-core[${PYTHON_USEDEP}]
	dev-python/twisted-names[${PYTHON_USEDEP}]
"
src_compile() {
	python setup.py build_ext
}

src_install() {
	python setup.py install --home "${D}" --install-purelib="${D}"usr/lib64/python2.7/site-packages --install-platlib="${D}"usr/lib64/python2.7/site-packages --install-scripts="${D}"/usr/bin --install-data="${D}"usr
}