view dev-db/pgpool-II/pgpool-II-2.2.1.ebuild @ 136:2cdc52664e30

bump rabbitmq to 1.6.0
author holger
date Wed, 17 Jun 2009 14:45:38 +0200
parents c6e067be5b97
children
line wrap: on
line source

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="New generation connection pool server for PostgreSQL"
HOMEPAGE="http://pgpool.projects.postgresql.org/"
SRC_URI="http://pgfoundry.org/frs/download.php/2108/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""

DEPEND="dev-db/postgresql-base"

src_unpack() {
	unpack ${A}
	S="${WORKDIR}/${PN}-2.2"
	cd ${S}
	sed -i -e "/^logdir/s:/tmp:/var/run:g" pgpool.conf.sample || die
}

src_compile() {
	econf --with-pgsql=/usr/include/postgresql || die
	emake || die
}

src_install () {
	einstall || die
	mv ${D}/etc/pcp.conf.sample ${D}/etc/pcp.conf
	mv ${D}/etc/pgpool.conf.sample ${D}/etc/pgpool.conf
	mv ${D}/etc/pool_hba.conf.sample ${D}/etc/pool_hba.conf
	dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO
	newinitd "${FILESDIR}/pgpool-II.init" pgpool-II || die "Inserting init.d-file failed"
}