Mercurial > hg > portage
view app-crypt/veracrypt/veracrypt-1.16.ebuild @ 532:31162884dfa0
1.48.2 update for vscodium
author | Dirk Olmes <dirk.olmes@codedo.de> |
---|---|
date | Sun, 30 Aug 2020 09:41:19 +0200 |
parents | c8888d18c151 |
children |
line wrap: on
line source
# Copyright 1999-2015 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Id$ EAPI="5" WX_GTK_VER="3.0" inherit unpacker wxwidgets DESCRIPTION="VeraCrypt is a free disk encryption software based on TrueCrypt" HOMEPAGE="https://veracrypt.codeplex.com" SRC_URI="https://github.com/veracrypt/VeraCrypt/archive/VeraCrypt_${PV}.tar.gz -> ${P}.tar.gz" LICENSE="truecrypt-3.0" SLOT="0" KEYWORDS="~amd64" IUSE="" RESTRICT="mirror" DEPEND=" sys-devel/make dev-lang/nasm app-arch/makeself sys-fs/fuse x11-libs/wxGTK:${WX_GTK_VER}[X] " RDEPEND="${DEPEND}" S=${WORKDIR} src_unpack() { unpack ${A} || die "Could not unpack!" mv ${WORKDIR}/* ${WORKDIR}/${PN} || die "Could not move directory!" return } src_compile() { cd ${WORKDIR}/${PN}/src make || die "Could not make VeraCrypt!" return } src_install() { exeinto /usr/bin doexe ${WORKDIR}/${PN}/src/Main/veracrypt || die "Could not install veracrypt executable!" insinto /usr/share/pixmaps doins "${FILESDIR}"/veracrypt.png || die "Could not copy veracrypt.png" return } pkg_postinst() { xdg-desktop-menu install --novendor "${FILESDIR}"/veracrypt.desktop || die "Could not register a menu item!" return } pkg_postrm() { xdg-desktop-menu uninstall "${FILESDIR}"/veracrypt.desktop || die "Could not de-register a menu item!" return }