Mercurial > hg > portage
view dev-util/bouml/bouml-4.6.1.ebuild @ 63:3ff7668d8ca2
remove bouml 4.6.1 as it's in the main portage
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Mon, 29 Sep 2008 12:06:38 +0200 |
parents | c23727376abb |
children |
line wrap: on
line source
# Copyright 1999-2007 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-4.6.1.ebuild,v 1.1 2008/09/25 13:14:06 ferdy Exp $ inherit multilib qt3 MY_P="${PN}_${PV}" DESCRIPTION="Free UML 2 tool with code generation" HOMEPAGE="http://bouml.free.fr/" SRC_URI="http://downloads.sourceforge.net/bouml/${MY_P}.tar.gz" LICENSE="GPL-2" SLOT="0" KEYWORDS="~amd64 ~x86 ~x86-fbsd" IUSE="" DEPEND="x11-libs/qt:3" #DEPEND="$(qt_min_version 3)" RDEPEND="${DEPEND}" S="${WORKDIR}/${MY_P}" src_compile() { find src/ genplugouts/ -type f -name "*.pro" | while read file; do local subdir="${file%/*}" eqmake3 "${file}" -o "${subdir}"/Makefile emake -C "${subdir}" || die "emake failed in ${subdir}" done } src_install() { emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \ || die "emake install failed" }