Mercurial > hg > portage
view dev-util/visualvm-bin/visualvm-bin-1.4.3.ebuild @ 482:46f0f228c4b5
updated ebuild for vscode 1.37.1
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 28 Aug 2019 13:56:13 +0200 |
parents | e3cfb359481d |
children |
line wrap: on
line source
# Copyright 1999-2018 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 EAPI=7 DESCRIPTION="Integrates commandline JDK tools and profiling capabilities" HOMEPAGE="https://visualvm.github.io" MY_PV="${PV//\./}" SRC_URI="https://github.com/visualvm/visualvm.src/releases/download/${PV}/visualvm_${MY_PV}.zip" S="${WORKDIR}/visualvm_${MY_PV}" SLOT="0" KEYWORDS="amd64" src_prepare() { default # Remove unneeded binaries rm bin/*.exe rm -rv platform/lib/*.{dll,exe} \ platform/modules/lib/{amd64/*.dll,i386,x86} || die find profiler/lib/deployed/jdk1? -mindepth 1 \ -maxdepth 1 ! -name linux-amd64 -exec rm -rv {} + || die } src_install() { local DEST_DIR="/opt/${PN}-${PV}" exeinto ${DEST_DIR}/bin doexe bin/visualvm insinto ${DEST_DIR} doins -r etc platform profiler visualvm }