view sys-libs/libstatgrab/libstatgrab-0.16.ebuild @ 31:51b6b390a7d8

pull changes from Holgi's portage tree
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 09 Jun 2008 01:42:38 +0200
parents 7985ba427c7d
children
line wrap: on
line source

# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstatgrab/libstatgrab-0.11.ebuild,v 1.1 2004/12/07 13:55:38 dragonheart Exp $

DESCRIPTION="Provides cross platform access to statistics about the system on which it's run."
HOMEPAGE="http://www.i-scream.org/libstatgrab/"
SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/${P}.tar.gz"

LICENSE="|| ( GPL-2 LGPL-2.1 )"
SLOT=0
KEYWORDS="~x86 ~ppc"
IUSE=""
RDEPEND=">=sys-libs/ncurses-5.4-r1
	virtual/libc"

DEPEND="${RDEPEND}
	sys-apps/gawk
	sys-apps/grep
	sys-devel/gcc
	dev-util/pkgconfig"

src_compile() {
	econf --disable-setgid-binaries --disable-setuid-binaries \
		--disable-deprecated --with-ncurses || die "econf failed"
	emake || die "emake failed"
}

src_install() {
	emake DESTDIR=${D} install || die "einstall failed"
	dodoc ChangeLog PLATFORMS NEWS AUTHORS README
}