Mercurial > hg > portage
view www-apps/radicale/radicale-2.1.8.ebuild @ 535:575a528bd6c9
vscodium update
author | Dirk Olmes <dirk.olmes@codedo.de> |
---|---|
date | Sat, 26 Sep 2020 13:03:43 +0200 |
parents | 510b2157b669 |
children |
line wrap: on
line source
# Copyright 1999-2017 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 EAPI=6 PYTHON_COMPAT=( python{3_4,3_5,3_6} ) inherit eutils distutils-r1 user MY_PN="Radicale" MY_P="${MY_PN}-${PV}" DESCRIPTION="A simple CalDAV calendar server" HOMEPAGE="http://www.radicale.org/" SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz" LICENSE="GPL-3" SLOT="0" KEYWORDS="~amd64 ~x86" IUSE="+bcrypt" DEPEND=" dev-python/vobject bcrypt? ( app-admin/apache-tools dev-python/passlib[bcrypt] )" S=${WORKDIR}/${MY_P} RDIR=/var/lib/radicale LDIR=/var/log/radicale pkg_setup() { enewgroup radicale enewuser radicale -1 -1 ${RDIR} radicale } python_install_all() { rm README* || die # init file newinitd "${FILESDIR}"/radicale.init.d radicale # directories diropts -m0750 dodir ${RDIR} fowners radicale:radicale ${RDIR} diropts -m0755 dodir ${LDIR} fowners radicale:radicale ${LDIR} # config file insinto /etc/${PN} doins config logging # fcgi and wsgi files exeinto /usr/share/${PN} doexe radicale.wsgi doexe radicale.fcgi distutils-r1_python_install_all } pkg_postinst() { einfo "A sample WSGI script has been put into ${ROOT}usr/share/${PN}." einfo "You will also find there an example FastCGI script." }