Mercurial > hg > portage
view sys-devel/gcc/gcc-4.3.1-r1.ebuild @ 53:5f7d8fd4d921
revbumps for e1000/e1000e
author | holger@hoho.dyndns.org |
---|---|
date | Fri, 04 Jul 2008 14:37:06 +0200 |
parents | 021734360017 |
children |
line wrap: on
line source
# Copyright 1999-2008 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.1.ebuild,v 1.4 2008/06/21 04:23:11 vapier Exp $ PATCH_VER="1.0" UCLIBC_VER="1.0" ETYPE="gcc-compiler" # whether we should split out specs files for multiple {PIE,SSP}-by-default # and vanilla configurations. SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed inherit toolchain DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking" LICENSE="GPL-2 LGPL-2.1" KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86" RDEPEND=">=sys-libs/zlib-1.1.4 >=sys-devel/gcc-config-1.4 virtual/libiconv >=dev-libs/gmp-4.2.1 >=dev-libs/mpfr-2.3 !build? ( gcj? ( gtk? ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto >=x11-libs/gtk+-2.2 x11-libs/pango ) >=media-libs/libart_lgpl-2.1 app-arch/zip app-arch/unzip ) >=sys-libs/ncurses-5.2-r2 nls? ( sys-devel/gettext ) )" DEPEND="${RDEPEND} test? ( sys-devel/autogen dev-util/dejagnu ) >=sys-apps/texinfo-4.2-r4 >=sys-devel/bison-1.875 amd64? ( >=sys-libs/glibc-2.7-r2 ) ppc? ( >=${CATEGORY}/binutils-2.17 ) ppc64? ( >=${CATEGORY}/binutils-2.17 ) >=${CATEGORY}/binutils-2.15.94" PDEPEND=">=sys-devel/gcc-config-1.4" if [[ ${CATEGORY} != cross-* ]] ; then PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )" fi src_unpack() { gcc_src_unpack use vanilla && return 0 [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch epatch "${FILESDIR}"/4.3.1/gcc-4.3.1-emit-rtl-Os.patch }