Mercurial > hg > portage
view net-misc/zmq/zmq-0.3.1.ebuild @ 80:6da0c8668e7e
add TODOs, verify that initial install works
author | holger@hoho.dyndns.org |
---|---|
date | Tue, 14 Oct 2008 04:50:48 +0200 |
parents | 7165b0bc5268 |
children |
line wrap: on
line source
# Copyright 1999-2008 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: $ inherit eutils DESCRIPTION="ZeroMQ is a brokerless messaging kernel with extremely high performance." HOMEPAGE="http://www.zeromq.org/" SRC_URI="http://www.zeromq.org/local--files/area:download/${P}.tar.gz" LICENSE="LGPL-3" SLOT="0" KEYWORDS="~x86" #IUSE="c examples java profile python" #DEPEND="" #RDEPEND="${DEPEND}" src_compile() { # TODO: # --with-perf build performance tests [default=no] # --with-camera build camera example [default=no] # --with-exchange build exchange example [default=no] # --with-chat build chatroom example [default=no] # --with-c build c language binding [default=no] # --with-python build Python language binding [default=no] # --with-java build Java language binding [default=no] econf \ emake || die "emake failed" } src_install() { emake DESTDIR="${D}" install || die "emake install failed" }