Mercurial > hg > portage
view dev-util/bouml/bouml-4.4.1.ebuild @ 71:71a512ce97e3
manifest-ebuild the new serendipity ebuild
author | root@gentoo.local |
---|---|
date | Tue, 30 Dec 2008 00:07:48 +0100 |
parents | 665fb2df350f |
children |
line wrap: on
line source
# Copyright 1999-2007 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.4.ebuild,v 1.1 2007/12/23 21:27:06 ferdy Exp $ inherit multilib qt3 MY_P="${PN}_${PV}" DESCRIPTION="Free UML 2 tool with code generation" HOMEPAGE="http://bouml.free.fr/" SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz" LICENSE="GPL-2" SLOT="0" KEYWORDS="~amd64 ~x86 ~x86-fbsd" IUSE="" DEPEND="x11-libs/qt:3" RDEPEND="${DEPEND}" S="${WORKDIR}/${MY_P}" src_compile() { find src/ genplugouts/ -type f -name "*.pro" | while read file; do local subdir="${file%/*}" eqmake3 "${file}" -o "${subdir}"/Makefile emake -C "${subdir}" || die "emake failed in ${subdir}" done } src_install() { emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \ || die "emake install failed" }