Mercurial > hg > portage
view dev-lang/dart/dart-1.20.1.ebuild @ 430:71a79165eb75
add an ebuild for the latest python-application version
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Sat, 03 Dec 2016 05:40:08 +0100 |
parents | 18fecfcfbe40 |
children |
line wrap: on
line source
EAPI=6 DESCRIPTION="Dart is an application programming language that’s easy to learn, easy to scale, and deployable everywhere." HOMEPAGE="https://www.dartlang.org" SRC_URI="https://storage.googleapis.com/dart-archive/channels/stable/release/${PV}/sdk/dartsdk-linux-x64-release.zip -> ${P}.zip" SLOT="0" KEYWORDS="amd64" S=${WORKDIR}/dart-sdk RDEPEND="sys-libs/glibc" src_compile() { :; } src_install() { local MY_DEST=/opt/dart-${PV} insinto ${MY_DEST} doins -r * for x in ${D}${MY_DEST}/bin/*; do if [ -f $x ]; then # fperms implicitly adds ${D} which we had to add for listing above chmod +x $x fi done chmod +x ${D}${MY_DEST}/lib/analysis_server/tool/spec/generate_files chmod +x ${D}${MY_DEST}/lib/analyzer/tool/generate_files dosym ${MY_DEST}/bin/dart /opt/bin/dart dosym ${MY_DEST}/bin/pub /opt/bin/pub }