Mercurial > hg > portage
view dev-java/maven-bin/maven-bin-3.0.0.ebuild @ 263:919d2e672e53
update to m3 final
author | holger |
---|---|
date | Wed, 13 Oct 2010 10:03:54 +0200 |
parents | dev-java/maven-bin/maven-bin-3.0.0_beta2.ebuild@2864788b37cf |
children |
line wrap: on
line source
# Copyright 1999-2010 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/dev-java/maven-bin/maven-bin-2.2.1.ebuild,v 1.3 2010/04/26 11:05:56 phajdan.jr Exp $ inherit java-pkg-2 inherit versionator MY_P="apache-maven-3.0" DESCRIPTION="Project Management and Comprehension Tool for Java" SRC_URI="mirror://apache/maven/binaries/${MY_P}-bin.tar.gz" HOMEPAGE="http://maven.apache.org/" LICENSE="Apache-2.0" SLOT="3.0" KEYWORDS="~amd64 ~ppc ~x86" RDEPEND=">=virtual/jdk-1.5 app-admin/eselect-maven" IUSE="" S="${WORKDIR}/${MY_P}" MAVEN=${PN}-${SLOT} MAVEN_SHARE="/usr/share/${MAVEN}" src_unpack() { unpack ${A} rm -v "${S}"/bin/*.bat || die } src_install() { dodir "${MAVEN_SHARE}" cp -Rp bin boot conf lib "${D}/${MAVEN_SHARE}" || die "failed to copy" java-pkg_regjar "${D}/${MAVEN_SHARE}"/lib/*.jar # the Maven distro comes with really weird permissions in the tarball # which will cause the ebuild to preserve these weird permissions, leaving # users with a broken maven installationy chown root: "${D}/${MAVEN_SHARE}"/lib/*.jar "${D}/${MAVEN_SHARE}"/boot/*.jar chmod 644 "${D}/${MAVEN_SHARE}"/lib/*.jar "${D}/${MAVEN_SHARE}"/boot/*.jar dodoc NOTICE.txt README.txt || die dodir /usr/bin dosym "${MAVEN_SHARE}/bin/mvn" /usr/bin/mvn-${SLOT} }