view app-arch/pigz/pigz-2.1.5.ebuild @ 175:9839e927aee2

add patch for gunzip compatibility to pigz-2.1.5
author holger
date Sat, 14 Nov 2009 20:06:57 +0100
parents 3b3ba42f2f0e
children
line wrap: on
line source

# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.1.5.ebuild,v 1.2 2009/11/02 17:58:48 vostorga Exp $

inherit eutils toolchain-funcs

DESCRIPTION="A parallel implementation of gzip."
HOMEPAGE="http://www.zlib.net/pigz/"
SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"

LICENSE="PIGZ"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE="test symlink"

RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}
	test? ( app-arch/ncompress )"

src_unpack() {
	unpack ${A}
	epatch "${FILESDIR}"/${P}-respect-flags.patch
	epatch "${FILESDIR}"/${P}-decode-symlinks-to-stdout.patch
	epatch "${FILESDIR}"/${P}-gunzip-compat.patch
}

src_compile() {
	tc-export CC
	emake || die "make failed"
}

src_install() {
	dobin ${PN} || die "Failed to install"
	dosym /usr/bin/pigz /usr/bin/unpigz
	dodoc README

	if use symlink; then
		dosym /usr/bin/pigz /usr/bin/gzip
		dosym /usr/bin/unpigz /usr/bin/gunzip
	fi
}