view net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild @ 60:acd741f300f7

it's alive
author holger@hoho.dyndns.org
date Fri, 15 Aug 2008 14:45:55 +0200
parents 6a65c52cb465
children
line wrap: on
line source

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils

DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang."
HOMEPAGE="http://www.rabbitmq.com/" 
SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz"
LICENSE="MPL"
SLOT="0" 
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
 
# Q: is RDEPEND-only sufficient for a binary package, since we don't compile?
DEPEND="dev-lang/erlang"
RDEPEND="${DEPEND}"

# grr: the packaged directory contains an underscore
S="${WORKDIR}/rabbitmq_server-${PV}"

src_install() {
	# the local erlang module directory
	local targetdir="/usr/$(get_libdir)/erlang/lib/${P}"

	# scripts
	dosbin sbin/*

	# erlang module
	dodir "${targetdir}"
	cp -dpR ebin include src "${D}/${targetdir}"

	# docs
	dodoc INSTALL LICENSE LICENSE-MPL-RabbitMQ

	# TODO:
	# config to set env vars as per INSTALL?
	# set LOGDIR to /var/log/rabbitmq.log
	# run as different user?
}