view net-misc/e1000e/e1000e-0.4.1.7.ebuild @ 67:b31e97231708

adding truecrypt ebuild
author Dirk Olmes <dirk.olmes@googlemail.com>
date Thu, 08 Jan 2009 10:07:25 +0100
parents 5f7d8fd4d921
children
line wrap: on
line source

# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
LICENSE="GPL-2"
DEPEND="virtual/linux-sources"

SRC_URI="mirror://sourceforge/e1000/${P}.tar.gz"
SLOT="0"
KEYWORDS="x86"
IUSE=""


src_unpack() {
    unpack ${A}
    cd ${S}/src
    # rem out the DEPVER line, since it would cause a sandbox violation and
    # since it is only needed by RPM ;-)
    sed -i "/^DEPVER :=/ d" Makefile
}


src_compile() {
    check_KV
    cd "${S}/src"

    # workaround needed for some ethernet controllers to work with low end switches
    if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
        then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
        else CFLAGS_EXTRA=""
    fi

    make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
}


src_install() {
    insinto "/lib/modules/${KV}/kernel/drivers/net/e1000e"
    doins "${S}/src/e1000e.ko"
    doman e1000e.7
    dodoc COPYING README SUMS e1000e.spec
    einfo ""
    einfo "In case you have problems when loading the module, try to run depmod -A"
    einfo ""
}