Mercurial > hg > portage
view dev-java/maven-bin/maven-bin-3.0.0.ebuild @ 247:ee84db816ec9
fix the RC3 ebuild (don't have the final tarball at hand right now)
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Mon, 04 Oct 2010 19:45:38 +0200 |
parents | 97d85f6a8c32 |
children | 2dcbfb21d30b |
line wrap: on
line source
# Copyright 1999-2010 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/dev-java/maven-bin/maven-bin-2.2.1.ebuild,v 1.3 2010/04/26 11:05:56 phajdan.jr Exp $ inherit java-pkg-2 inherit versionator MY_P="apache-maven-3.0" DESCRIPTION="Project Management and Comprehension Tool for Java" SRC_URI="mirror://apache/maven/binaries/${MY_P}-bin.tar.gz" HOMEPAGE="http://maven.apache.org/" LICENSE="Apache-2.0" SLOT="3.0" KEYWORDS="~amd64 ~ppc ~x86" RDEPEND=">=virtual/jdk-1.5 app-admin/eselect-maven" IUSE="" S="${WORKDIR}/${MY_P}" MAVEN=${PN}-${SLOT} MAVEN_SHARE="/usr/share/${MAVEN}" src_unpack() { unpack ${A} rm -v "${S}"/bin/*.bat || die } # TODO we should use jars from packages, instead of what is bundled src_install() { dodir "${MAVEN_SHARE}" cp -Rp bin boot conf lib "${D}/${MAVEN_SHARE}" || die "failed to copy" java-pkg_regjar "${D}/${MAVEN_SHARE}"/lib/*.jar dodoc NOTICE.txt README.txt || die dodir /usr/bin dosym "${MAVEN_SHARE}/bin/mvn" /usr/bin/mvn-${SLOT} }