changeset 286:0256a54aeb68

bump Zookeeper to 3.3.3, fix ebuild since TLP move
author holger
date Mon, 04 Apr 2011 15:26:16 +0200
parents 8679a9a2a216
children de70db54f512
files sys-cluster/zookeeper/Manifest sys-cluster/zookeeper/zookeeper-3.3.1.ebuild sys-cluster/zookeeper/zookeeper-3.3.3.ebuild
diffstat 3 files changed, 72 insertions(+), 73 deletions(-) [+]
line wrap: on
line diff
--- a/sys-cluster/zookeeper/Manifest	Fri Apr 01 17:25:41 2011 +0200
+++ b/sys-cluster/zookeeper/Manifest	Mon Apr 04 15:26:16 2011 +0200
@@ -1,2 +1,2 @@
-DIST zookeeper-3.3.1.tar.gz 10279804 RMD160 a911202f6271901cc6fb4b64306808f64bff6e99 SHA1 683f439c149fdeaad996eb88d84caa2f2fc756c5 SHA256 dc77ef79aea6b19d418110e9a1e916cb4c26ceb7b3acb6792af32eb2a97ea536
-EBUILD zookeeper-3.3.1.ebuild 1522 RMD160 05f6dc9a9aa92f3444bd3233061a9c22749acb79 SHA1 add0d228a8885af2aea4273314147c65ffe716da SHA256 521bd45843722d5ed0be7da8371616edc276b509ec8c5a26dc46dd640ef53033
+DIST zookeeper-3.3.3.tar.gz 9639959 RMD160 c245ecbdf921f70ab4b4f5c9593452f9b3bea5c3 SHA1 66b62b71947df7b5f12a77a8435c332e6959dac8 SHA256 70808f5492ca1f9bec1ed7b129f2f7cb97df821ae04a6af9e99f23cdabe4f1d4
+EBUILD zookeeper-3.3.3.ebuild 1518 RMD160 e681302c1587e684fcc404614154e99fe613cd68 SHA1 0e69f31b0e3548bf5862cd3e1aa6dd789da12009 SHA256 33847dd8a848f2dbcdd70b235337fac8677a32aba009fff167963cf01019109a
--- a/sys-cluster/zookeeper/zookeeper-3.3.1.ebuild	Fri Apr 01 17:25:41 2011 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils java-utils-2
-
-MY_PN="${PN/apache-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="ZooKeeper is a high-performance coordination service for
-distributed applications."
-HOMEPAGE="http://hadoop.apache.org/"
-SRC_URI="mirror://apache/hadoop/${MY_PN}/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror binchecks"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=virtual/jre-1.6"
-
-S="${WORKDIR}/${MY_P}"
-INSTALL_DIR=/opt/"${PN}"
-DATA_DIR=/var/db/"${PN}"
-export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"
-
-src_install() {
-	dodir "${DATA_DIR}"
-	sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die "sed failed"
-
-	dodir "${INSTALL_DIR}"
-	mv "${S}"/* "${D}${INSTALL_DIR}" || die "install failed"
-
-	# env file
-	cat > 99"${PN}" <<-EOF
-		PATH=${INSTALL_DIR}/bin
-		CONFIG_PROTECT=${INSTALL_DIR}/conf
-	EOF
-	doenvd 99"${PN}" || die "doenvd failed"
-
-	cat > "${PN}" <<-EOF
-		#!/sbin/runscript
-
-		opts="start stop restart"
-
-		start() {
-			${INSTALL_DIR}/bin/zkServer.sh start > /dev/null
-				}
-
-		stop() {
-			${INSTALL_DIR}/bin/zkServer.sh stop
-				}
-
-		restart() {
-			${INSTALL_DIR}/bin/zkServer.sh restart > /dev/null
-				}
-
-		status() {
-			${INSTALL_DIR}/bin/zkServer.sh status
-				}
-	EOF
-	doinitd "${PN}" || die "doinitd failed"
-}
-
-pkg_postinst() {
-	elog "For info on configuration see http://hadoop.apache.org/${MY_PN}/docs/r${PV}"
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-cluster/zookeeper/zookeeper-3.3.3.ebuild	Mon Apr 04 15:26:16 2011 +0200
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils java-utils-2
+
+MY_PN="${PN/apache-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ZooKeeper is a high-performance coordination service for distributed applications."
+HOMEPAGE="http://zookeeper.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror binchecks"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR=/opt/"${PN}"
+DATA_DIR=/var/db/"${PN}"
+export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"
+
+src_install() {
+	dodir "${DATA_DIR}"
+	sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die "sed failed"
+
+	dodir "${INSTALL_DIR}"
+	mv "${S}"/* "${D}${INSTALL_DIR}" || die "install failed"
+
+	# env file
+	cat > 99"${PN}" <<-EOF
+		PATH=${INSTALL_DIR}/bin
+		CONFIG_PROTECT=${INSTALL_DIR}/conf
+	EOF
+	doenvd 99"${PN}" || die "doenvd failed"
+
+	cat > "${PN}" <<-EOF
+		#!/sbin/runscript
+
+		opts="start stop restart"
+
+		start() {
+			${INSTALL_DIR}/bin/zkServer.sh start > /dev/null
+				}
+
+		stop() {
+			${INSTALL_DIR}/bin/zkServer.sh stop
+				}
+
+		restart() {
+			${INSTALL_DIR}/bin/zkServer.sh restart > /dev/null
+				}
+
+		status() {
+			${INSTALL_DIR}/bin/zkServer.sh status
+				}
+	EOF
+	doinitd "${PN}" || die "doinitd failed"
+}
+
+pkg_postinst() {
+	elog "For info on configuration see http://hadoop.apache.org/${MY_PN}/docs/r${PV}"
+}