changeset 393:1135ba64f157

update psi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Wed, 03 Jun 2015 14:49:47 +0200
parents 19a5242dd10f
children 323ff9881d83
files net-im/psi-plus/Manifest net-im/psi-plus/psi-plus-0.16.451.ebuild
diffstat 2 files changed, 140 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- a/net-im/psi-plus/Manifest	Mon May 11 07:48:16 2015 +0200
+++ b/net-im/psi-plus/Manifest	Wed Jun 03 14:49:47 2015 +0200
@@ -1,2 +1,5 @@
+AUX configure.patch 444 SHA256 f1089dadbd539c4b13e955d0ce534d29007d02033f3a8dd3b44e7ad6ae782a0d SHA512 fad2b631f2b7b240abbd22de8c2584300d9723cad1f0f841473a08e2027a875038b37aa1ea93507d7dd2cb1eff94bf1d2f52f9ddf21bef3b85221b3f0e03f302 WHIRLPOOL 3585e069a5dfcfd5909ebd26aca7949850a3d7a560fdc5a8ce719d68aa7c8c5323f7aa0fa6b8830f47405e28170be74ebb53d03a7d26f0ab9e978731745c9926
 DIST 0.16.449.tar.gz 8277518 SHA256 3c3e0f464dc342f6803adca0294b6943d19113799c678bf58233a6dc59783e68 SHA512 8c1053e573ac255e0654fad430a065c9d67144a775e3cde47f0a94b07d642816630a2cee9e5e8e62da0f1f4d70c495289b525b40cbc8eea629fa316f3928f365 WHIRLPOOL cc304c34b639cd1c7d8a469f877612422e5e87153b8d21f51622ac6537d562ce3733b751264533bf24d2e215b73c3c5f51bf8d57d0068bf9624bde658ea50836
+DIST 0.16.451.tar.gz 8276448 SHA256 131ca10f8c7f57d90a21e7f1e2f5656366ef96ab4eefa625fc5b9e313d52c749 SHA512 e67eb9845d949effe9d23189ec60e6ba04b25e8b857fd8ed679ab7087d29c71065ed59cc45a5863f4c7626ff6a002e4a72c54791e4e8e64d739122d48a27546d WHIRLPOOL b04c082e5ff5fe75dfe536d5b2b6ebf6021388c43995875b40b49fb449243a2e025009df47910023f1acf1963525f8f6b25e284e788a9f53f736a4f97ae52791
 EBUILD psi-plus-0.16.449.ebuild 2966 SHA256 5e7331db84666a4625faa78ca36fe70356c9095fbe31acd7410e638b8ca0c707 SHA512 c31e89d6b6049c0224ab6882983dde0171505ecde8e2435bd022a6c4a8f9e489e79998f5b2d2d9702c78b51e4e98d4ef2374263d6ee0dc8da220b944da3157c5 WHIRLPOOL 19e29f9de540fbadb3a186c0599506a4f34b98a53fde56d0a4a8c8bb24c787237876cff8e50766374f0900e2f5b82b2c832bb042e05a8cbdd0eb1fe1046be985
+EBUILD psi-plus-0.16.451.ebuild 3005 SHA256 9219c6eae1424b0bad2849438c489a2026470449e3b740415313c9cffc74c7c8 SHA512 918d5ef71fac33a92e4b327f5aef4e34122f3329549311a230be0f2fc9922d1dfd8d93a6640b65cc21d9bed23741e848619ff0b00097b7f1309400055f1eef72 WHIRLPOOL de95536df386b114e2ea6af64edcf8ca270ebfff02bd1bb29b705b7f70b580ff20772ea90499240654260d23616b7ee1576026ec69a7739bff8f1ffb08e37872
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-im/psi-plus/psi-plus-0.16.451.ebuild	Wed Jun 03 14:49:47 2015 +0200
@@ -0,0 +1,137 @@
+
+EAPI=5
+
+inherit eutils l10n multilib gnome2-utils qt4-r2
+
+DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
+HOMEPAGE="https://github.com/psi-plus/psi-plus-snapshots/"
+SRC_URI="https://github.com/psi-plus/psi-plus-snapshots/archive/${PV}.tar.gz"
+
+S="${WORKDIR}/psi-plus-snapshots-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding"
+#RESTRICT="test"
+
+RDEPEND="app-arch/unzip
+	>=dev-qt/qtgui-4.7:4
+	>=app-crypt/qca-2.0.2:2[qt4(+)]
+	x11-libs/libX11
+	dbus? ( >=dev-qt/qtdbus-4.7:4 )
+	spell? ( >=app-text/enchant-1.3.0 )
+	xscreensaver? ( x11-libs/libXScrnSaver )
+	whiteboarding? ( dev-qt/qtsvg:4 )
+	|| ( >=sys-libs/zlib-1.2.5.1-r2[minizip] <sys-libs/zlib-1.2.5.1-r1 )"
+
+DEPEND="${RDEPEND}
+	sys-devel/qconf
+	doc? ( app-doc/doxygen )"
+
+PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
+	jingle? ( net-im/psimedia
+		app-crypt/qca:2[openssl] )
+	ssl? ( app-crypt/qca:2[openssl] )
+	otrplugin? ( net-libs/libotr app-text/htmltidy )"
+
+src_prepare() {
+	#epatch "${FILESDIR}/configure.patch"
+	epatch_user
+}
+
+src_configure() {
+	# unable to use econf because of non-standard configure script
+	local confcmd="./configure
+		--prefix=/usr
+		--datadir=/usr/share
+		--libdir=/usr/lib64
+		--disable-growl
+		$(use dbus || echo '--disable-qdbus')
+		$(use debug && echo '--debug')
+		$(use plugins && echo '--enable-plugins')
+		$(use spell || echo '--disable-aspell')
+		$(use spell || echo '--disable-enchant')
+		$(use xscreensaver || echo '--disable-xss')
+		$(use whiteboarding && echo '--enable-whiteboarding')"
+
+	echo ${confcmd}
+	${confcmd} || die "configure failed"
+	## Makefile is not always created...
+	#[[ ! -f Makefile ]] && die "configure failed"
+}
+
+src_compile() {
+	emake || die "emake failed"
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+	
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+	dodoc README TODO ChangeLog
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libautoreplyplugin.so
+
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libotrplugin.so
+
+		cd ../../../..
+	fi
+
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libwatcherplugin.so
+
+		cd ../../../..
+	fi
+}
+
+pkg_preinst() {
+	gnome2_icon_savelist
+}
+
+pkg_postinst() {
+	gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}