changeset 25:126096e3d51b

added ebuilds from the svn portage tree
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 26 May 2008 16:41:22 +0200
parents 41713688d1e0
children 31f34c64d33d
files dev-db/pgadmin3/Manifest dev-db/pgadmin3/pgadmin3-1.6.3.ebuild dev-db/pgadmin3/pgadmin3-1.8.2.ebuild dev-util/bouml/Manifest dev-util/bouml/bouml-4.2.ebuild dev-util/bouml/bouml-4.3.2.ebuild mail-filter/spambayes/Manifest mail-filter/spambayes/spambayes-1.0.1.ebuild mail-filter/spambayes/spambayes-1.0.3.ebuild mail-filter/spambayes/spambayes-1.0.4.ebuild
diffstat 10 files changed, 350 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgadmin3/Manifest	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,4 @@
+DIST pgadmin3-1.6.3.tar.gz 8353446 RMD160 2e30091a694042f06c28811b63863e06759bcc48 SHA1 3c56fbbec37a6d4ef5def0c1c0f775b177d4805d SHA256 e84614ab3ed3b455f88e0dce4e3880caf7cf535ed999e97d825af429f25f294b
+DIST pgadmin3-1.8.2.tar.gz 7951378 RMD160 302039687dac63e221844c21c0dfae8f042f3d92 SHA1 dc3117fb84dc77f13a2cf0518e46cd6067eaed15 SHA256 f86b84911b27e835810182443b20cf7826fe30af199d9abb2668502a7f10ec8f
+EBUILD pgadmin3-1.6.3.ebuild 1500 RMD160 7f6745a96e8370d51913a988d26f6440391aa801 SHA1 b25740a48c86506cb1481d5c03b16a4e2be6665f SHA256 b519b527d3ec927d9f975c45fc08cdc91f288bfc136937202a1bfc57cb42dc44
+EBUILD pgadmin3-1.8.2.ebuild 1533 RMD160 5f162e89f176757d31eabfd533092e3306754c9f SHA1 292693ca53f09e074145c99869534b02ad698164 SHA256 1a05f3f1bd1f36d144eea0c3176484caad2baea6d8730e7f140b3fc496d98196
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgadmin3/pgadmin3-1.6.3.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# 
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="=x11-libs/wxGTK-2.8*
+		>=dev-db/libpq-7.4
+		>=dev-libs/libxml2-2.5
+		>=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+	export WX_GTK_VER=2.8
+	export WX_HOME=/usr
+	need-wxwidgets unicode
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	# --debug=yes/no for wx_config is only needed if wxGTK debug and
+	# release versions are installed aside. Which is not possible
+	# on Gentoo at the moment.
+	sed -i \
+		-e 's/--debug=[yesno]* //g' \
+		acinclude.m4 || die "sed failed"
+	eautoreconf
+}
+
+src_compile() {
+	cd "${S}"
+	patch -p0 < ${FILESDIR}/patch.p0
+	# pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
+	econf \
+		--with-wx-config=/${WX_CONFIG/\ /usr} \
+                --with-wx-version=2.8  \
+		|| die "econf failed"
+	emake || die "emake failed"
+}
+
+src_install() {
+	cd "${S}"
+
+	einstall || die "einstall failed"
+
+	insinto /usr/share/pixmaps
+	newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+	insinto /usr/share/pgadmin3
+	newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+	insinto /usr/share/applications
+	doins "${S}/pkg/pgadmin3.desktop"
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-db/pgadmin3/pgadmin3-1.8.2.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# 
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV/_/-}/src/${P/_/-}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+S="${WORKDIR}/${P/_/-}"
+
+DEPEND="=x11-libs/wxGTK-2.8*
+		>=dev-db/libpq-8
+		>=dev-libs/libxml2-2.6.18
+		>=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+	export WX_GTK_VER=2.8
+	export WX_HOME=/usr
+	need-wxwidgets unicode
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}"
+
+	# --debug=yes/no for wx_config is only needed if wxGTK debug and
+	# release versions are installed aside. Which is not possible
+	# on Gentoo at the moment.
+	sed -i \
+		-e 's/--debug=[yesno]* //g' \
+		acinclude.m4 || die "sed failed"
+	eautoreconf
+}
+
+src_compile() {
+	cd "${S}"
+	patch -p0 < ${FILESDIR}/patch.p0
+	# pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
+	econf \
+		--with-wx-config=/${WX_CONFIG/\ /usr} \
+                --with-wx-version=2.8  \
+		|| die "econf failed"
+	emake || die "emake failed"
+}
+
+src_install() {
+	cd "${S}"
+
+	einstall || die "einstall failed"
+
+	insinto /usr/share/pixmaps
+	newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+	insinto /usr/share/pgadmin3
+	newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+	insinto /usr/share/applications
+	doins "${S}/pkg/pgadmin3.desktop"
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-util/bouml/Manifest	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,4 @@
+DIST bouml_4.2.tar.gz 4485084 RMD160 f30c60de28183de63d300285da59a09ed2c8ab16 SHA1 9beb1fa0404f4f8fc5fc75be16f8daebd6fb6a8f SHA256 c6ce803a850970a52992ec7ee9e44d25d311f222b55b7c12dff61b691e110f44
+DIST bouml_4.3.2.tar.gz 4603743 RMD160 b14805d7a7b4dabac1dba78619a4621ff04a358d SHA1 409b3e2fa7b4d492caa822b9d23cfe0de6b633c6 SHA256 6358e4843044325406ec7cc5bf233e6e96ce9c0e7fc1ab0e8eb9d6349a99c9ee
+EBUILD bouml-4.2.ebuild 869 RMD160 d00fdbece599ba8cc7bdd3dcaf4015c98b2753a7 SHA1 ef8b0fce1ed75c01c887ff6506fda51a0e1e8abc SHA256 55a9821125e716258eba66cd1caafce126ada1e9b0cd05d46d3a5af9e0232099
+EBUILD bouml-4.3.2.ebuild 869 RMD160 d00fdbece599ba8cc7bdd3dcaf4015c98b2753a7 SHA1 ef8b0fce1ed75c01c887ff6506fda51a0e1e8abc SHA256 55a9821125e716258eba66cd1caafce126ada1e9b0cd05d46d3a5af9e0232099
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-util/bouml/bouml-4.2.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.4.ebuild,v 1.1 2007/12/23 21:27:06 ferdy Exp $
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+	find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+		local subdir="${file%/*}"
+		eqmake3 "${file}" -o "${subdir}"/Makefile
+		emake -C "${subdir}" || die "emake failed in ${subdir}"
+	done
+}
+
+src_install() {
+	emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+		|| die "emake install failed"
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-util/bouml/bouml-4.3.2.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.4.ebuild,v 1.1 2007/12/23 21:27:06 ferdy Exp $
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+	find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+		local subdir="${file%/*}"
+		eqmake3 "${file}" -o "${subdir}"/Makefile
+		emake -C "${subdir}" || die "emake failed in ${subdir}"
+	done
+}
+
+src_install() {
+	emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+		|| die "emake install failed"
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-filter/spambayes/Manifest	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,6 @@
+DIST spambayes-1.0.1.tar.gz 688955 RMD160 77a66c0d147a6f273029f67f0770129101c5cbd3 SHA1 07bfea7886c9941458c2688dc01a4deb041d8f31 SHA256 3f0417b4d1e7019bacddd4b817401aea7755a9cdafc04a31ba53d37ed348998e
+DIST spambayes-1.0.3.tar.gz 696822 RMD160 689926117f4896abc5d7fc27f712b335241359df SHA1 30a0cdc11741ed1d86a9b0964c0fd756b56174e2 SHA256 db9f50e4518e1cc9e809ed3c516e41f7bae3da49a7f8990e9da6722a643f3e68
+DIST spambayes-1.0.4.tar.gz 697781 RMD160 6dfbaa5cc7eb14d9ddbb68c381580e793cb9c28e SHA1 a7b92eb8465a6ac093d29e64c539ff8348b08c26 SHA256 53c498d98e2f0a88d6edb928e3e1abcf65fc4aee8a98e142175809b9409d30aa
+EBUILD spambayes-1.0.1.ebuild 1325 RMD160 ae6368e1d23e9e682cf512e59e91fd856de1d026 SHA1 1146a78562f9ca29bb154ef5b06b1b97c40c4bf3 SHA256 838f9b65d91b7fbaf5be9d8f6a807c7773074ea618440dd10c07ccd2f4ceac42
+EBUILD spambayes-1.0.3.ebuild 1325 RMD160 d70828530277153d87d276b40bcf891537ba43cc SHA1 3874bda86ebd71f7eb908ecdff42daf4262fa29f SHA256 4cbb1d41bb863f072f3051d67aba8f253db8736916718cad0af78017b319c5b9
+EBUILD spambayes-1.0.4.ebuild 1185 RMD160 c76faeca416fcf186170c1915aab4e284d1afade SHA1 54189565f5a125149516f3f442c5f289b42ef086 SHA256 1afc17bef3bb06791632a2b448d3b0e5ab64c63e39ff0404c33e217b1f1f312f
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-filter/spambayes/spambayes-1.0.1.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spambayes/spambayes-1.0_rc1.ebuild,v 1.3 2004/06/24 22:22:43 agriffis Exp $
+
+inherit distutils
+
+DESCRIPTION="An anti-spam filter using on Bayesian filtering"
+HOMEPAGE="http://spambayes.sourceforge.net"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="http://mesh.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2.2"
+
+# removing ".1" from the work directory name
+#S=${WORKDIR}/${MY_P/.1}
+
+src_install() {
+
+	distutils_src_install
+	dodoc *.txt || die "doc *.txt files failed"
+
+	# someone might have benefits of the other documetation too,
+	# therefore added.
+
+	docinto contrib || die "doc directory, contrib, fail"
+	dodoc contrib/* || die "doc contrib/* failed"
+	docinto utilities || die "doc directory, utilities, failed"
+	dodoc utilities/* || die "doc utilities/* failed"
+	docinto testtools || die "doc directory, testtools, failed"
+	dodoc testtools/* || die "doc testtools/* failed"
+
+	exeinto /etc/init.d
+	newexe ${FILESDIR}/spambayespop3proxy.rc spambayespop3proxy
+
+	insinto /etc
+	doins ${FILESDIR}/bayescustomize.ini
+
+	keepdir /var/lib/spambayes
+
+}
+
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-filter/spambayes/spambayes-1.0.3.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spambayes/spambayes-1.0_rc1.ebuild,v 1.3 2004/06/24 22:22:43 agriffis Exp $
+
+inherit distutils
+
+DESCRIPTION="An anti-spam filter using on Bayesian filtering"
+HOMEPAGE="http://spambayes.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+#SRC_URI="http://mesh.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2.2"
+
+# removing ".1" from the work directory name
+#S=${WORKDIR}/${MY_P/.1}
+
+src_install() {
+
+	distutils_src_install
+	dodoc *.txt || die "doc *.txt files failed"
+
+	# someone might have benefits of the other documetation too,
+	# therefore added.
+
+	docinto contrib || die "doc directory, contrib, fail"
+	dodoc contrib/* || die "doc contrib/* failed"
+	docinto utilities || die "doc directory, utilities, failed"
+	dodoc utilities/* || die "doc utilities/* failed"
+	docinto testtools || die "doc directory, testtools, failed"
+	dodoc testtools/* || die "doc testtools/* failed"
+
+	exeinto /etc/init.d
+	newexe ${FILESDIR}/spambayespop3proxy.rc spambayespop3proxy
+
+	insinto /etc
+	doins ${FILESDIR}/bayescustomize.ini
+
+	keepdir /var/lib/spambayes
+
+}
+
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/mail-filter/spambayes/spambayes-1.0.4.ebuild	Mon May 26 16:41:22 2008 +0200
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spambayes/spambayes-1.0.4.ebuild,v 1.0 2005/04/08 22:22:43 userwaldo Exp $
+
+inherit distutils
+
+DESCRIPTION="An anti-spam filter using on Bayesian filtering"
+HOMEPAGE="http://spambayes.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2.2"
+
+src_install() {
+	distutils_src_install
+	dodoc *.txt || die "doc *.txt files failed"
+	# someone might have benefits of the other documetation too,
+	# therefore added.
+	docinto contrib || die "doc directory, contrib, fail"
+	dodoc contrib/* || die "doc contrib/* failed"
+	docinto utilities || die "doc directory, utilities, failed"
+	dodoc utilities/* || die "doc utilities/* failed"
+	docinto testtools || die "doc directory, testtools, failed"
+	dodoc testtools/* || die "doc testtools/* failed"
+
+	exeinto /etc/init.d
+	newexe ${FILESDIR}/spambayespop3proxy.rc spambayespop3proxy
+
+	insinto /etc
+	doins ${FILESDIR}/bayescustomize.ini
+
+	keepdir /var/lib/spambayes
+
+}
+