changeset 402:1d67465feb67

add a ebuild for docker-compose-bin
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 09 Nov 2015 19:42:01 +0100
parents 261f734e7c25
children 3931bbd1a475
files app-emulation/docker-compose-bin/Manifest app-emulation/docker-compose-bin/docker-compose-bin-1.5.0.ebuild
diffstat 2 files changed, 31 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-emulation/docker-compose-bin/Manifest	Mon Nov 09 19:42:01 2015 +0100
@@ -0,0 +1,2 @@
+DIST docker-compose-bin-1.5.0-Linux-x86_64 7922818 SHA256 f920ae9e3907b5007d3d833f1d369f908eeeabf31f292130636102b0c9b6ddf1 SHA512 ddad11180d956cad902440ce48062dfe41eb6f076707a603891de45e3315c5ff6bc17001e04aea9ff422935347b9ba80afda7c139e96fe61c9ff6ff3150b3385 WHIRLPOOL 6be6daf14ce17e2014c15b4cfaef13947eb1120184e10845f71cf984bf70662fca6de637f31304c5d2056f7a985adb28847442ffd060294c6ce386b3cd939618
+EBUILD docker-compose-bin-1.5.0.ebuild 618 SHA256 1ad670d6a20473b58a0bdcd2db7c1508a68e7b709ad313d14705a2840ea1e2d6 SHA512 fdc0cf63f58e7b68dcc0d1ec9b4e3eae09a60cb79786d7f512ed2d546fafda580f5d2f5a9efb1de32c8b80c29abcfff4148c4ec296a0bc544c19a38397da2b37 WHIRLPOOL d40168dfa361ec3b101d7980b40096ad8da0801effb716ed36f8977ce70e29f723addc4d1529d7fa60d57d5eed7cc6195bd723692fdfa0952e279273eb75cec4
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/app-emulation/docker-compose-bin/docker-compose-bin-1.5.0.ebuild	Mon Nov 09 19:42:01 2015 +0100
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Compose is a tool for defining and running complex applications with Docker"
+HOMEPAGE="https://docs.docker.com/compose/"
+MY_PN="${PN%-bin}"
+MY_PV="${PV/_/}"
+SRC_URI="
+	amd64? ( https://github.com/docker/compose/releases/download/${MY_PV}/${MY_PN}-Linux-x86_64 -> ${P}-Linux-x86_64 )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+RESTRICT="installsources strip"
+
+S="${DISTDIR}"
+
+src_install() {
+	newbin ${P}-Linux-x86_64 ${MY_PN}
+}