changeset 29:2ab9bb2b8fa8

add new leafnode alpha build
author holger@hoho.dyndns.org
date Sat, 07 Jun 2008 20:30:53 +0200
parents 04cba7df88a1
children 73894a55faf6
files net-nntp/leafnode/files/fetchnews.cron net-nntp/leafnode/files/leafnode.xinetd net-nntp/leafnode/files/local.groups net-nntp/leafnode/files/moderators net-nntp/leafnode/files/texpire.cron net-nntp/leafnode/leafnode-2.0.0_alpha20070602.ebuild
diffstat 6 files changed, 96 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/fetchnews.cron	Sat Jun 07 20:30:53 2008 +0200
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# Uncomment the following if you want to regularly
+# fetch new messages from your news server. 
+#
+#
+# This is part of the leafnode package.
+#
+
+#/usr/sbin/fetchnews 
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/leafnode.xinetd	Sat Jun 07 20:30:53 2008 +0200
@@ -0,0 +1,12 @@
+# default: off
+# description: Leafnode - accepts connections on port 119 (NNTP)
+
+service nntp
+{
+	socket_type = stream
+	protocol    = tcp
+	wait        = no
+	user        = news
+	server      = /usr/sbin/leafnode
+	disable     = yes
+}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/local.groups	Sat Jun 07 20:30:53 2008 +0200
@@ -0,0 +1,2 @@
+local.testing	y	local group for testing
+local.special	m	local group with moderator
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/moderators	Sat Jun 07 20:30:53 2008 +0200
@@ -0,0 +1,1 @@
+local.special:root@localhost
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/files/texpire.cron	Sat Jun 07 20:30:53 2008 +0200
@@ -0,0 +1,10 @@
+#!/bin/sh
+#
+# Uncomment the following if you want to
+# clean up your news spool regularly.
+# 
+#
+# This is part of the leafnode package.
+#
+
+#/usr/sbin/texpire
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-nntp/leafnode/leafnode-2.0.0_alpha20070602.ebuild	Sat Jun 07 20:30:53 2008 +0200
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/leafnode/leafnode-2.0.0_alpha20070108.ebuild,v 1.1 2007/02/18 21:13:31 swegener Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/.}a
+
+DESCRIPTION="A USENET software package designed for small sites"
+SRC_URI="http://www-dt.e-technik.uni-dortmund.de/~ma/leafnode/beta/${MY_P}.tar.bz2"
+HOMEPAGE="http://www-dt.e-technik.uni-dortmund.de/~ma/leafnode/beta/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="ipv6 pam"
+
+DEPEND=">=dev-libs/libpcre-3.9
+	pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+	virtual/inetd"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+	append-ldflags $(bindnow-flags)
+
+	econf \
+		--sysconfdir=/etc/leafnode \
+		--with-runas-user=news \
+		--localstatedir=/var \
+		--with-spooldir=/var/spool/news \
+		$(use_with ipv6) \
+		$(use_with pam) \
+		|| die "econf failed"
+	emake || die "emake failed"
+}
+
+src_install() {
+	make DESTDIR="${D}" install || die "make install failed"
+
+	keepdir \
+		/var/lock/news \
+		/var/lib/news \
+		/var/spool/news
+
+	insinto /etc/leafnode
+	doins "${FILESDIR}"/{local.groups,moderators} || die "doins failed"
+
+	insinto /etc/xinetd.d
+	newins "${FILESDIR}"/leafnode.xinetd leafnode-nntp || die "newins failed"
+
+	exeinto /etc/cron.hourly
+	newexe "${FILESDIR}"/fetchnews.cron fetchnews || die "doexe failed"
+	exeinto /etc/cron.daily
+	newexe "${FILESDIR}"/texpire.cron texpire || die "doexe failed"
+
+	dodoc \
+		AUTHORS COPYING* CREDITS ChangeLog DEBUGGING ENVIRONMENT \
+		INSTALL NEWS TODO README || die "dodoc failed"
+	dohtml README.html || die "dohtml failed"
+}