changeset 151:2c475c91786e

update samba to 3.3.7
author holger
date Tue, 04 Aug 2009 14:41:58 +0200
parents 656932afd91c
children 2cb495e793ae
files net-fs/samba/Manifest net-fs/samba/samba-3.3.6.ebuild net-fs/samba/samba-3.3.7.ebuild
diffstat 3 files changed, 267 insertions(+), 267 deletions(-) [+]
line wrap: on
line diff
--- a/net-fs/samba/Manifest	Fri Jul 24 13:57:01 2009 +0200
+++ b/net-fs/samba/Manifest	Tue Aug 04 14:41:58 2009 +0200
@@ -11,6 +11,6 @@
 AUX samba-conf 1291 RMD160 326fb4beee8105d839d23e37f4989d7e332c996b SHA1 af7cd695f212d7ec022df05ba2f821a8f9878ab2 SHA256 dfaf474c3cbfa3d3b26d1531c6f5913739d5815c4b8083063934ee4fd6b38861
 AUX samba-init 1133 RMD160 77a084e8f78665af0233f19dc9c4a49693360da1 SHA1 09d7f1d676856289b61e890396a9976e2ccc794a SHA256 3b41d16daf02f9a1ab12e62c4c915f58e7801c07be48e2a94086eb288bb86aad
 AUX samba-xinetd 286 RMD160 c90bd8518082eb4c182d5f7bd223a76f8e3c7fab SHA1 b250c5ca539187d8b481bcfb6ea3a915d7e8b26b SHA256 964d06dc33beff38978a8f03cd12b05c33d8258ed73aa9ffbf137fe226de25b8
-DIST samba-3.3.6.tar.gz 26097470 RMD160 a4759d23e3e264dcb5902b36794d2102aab2f494 SHA1 e6dea0bc938bd74e593a78c23afb55574edfba9a SHA256 da66e05f87ce6540ef709fbd347a706bc8e3b69cfab568ebf58bfe2e9ed44263
-EBUILD samba-3.3.6.ebuild 7593 RMD160 b7bdd2cf043878df2b4392391f4f47ebf1bb4b48 SHA1 b15a0ef7b58c2f20863ca455f8bfa36ee0de193d SHA256 e9391c54879e636afdff5b505d8a183dbf31169ce3151e6a62474afd5d9048be
+DIST samba-3.3.7.tar.gz 26096144 RMD160 ec82cc23a2799b06c1bd2cd59aca9e78fb814fc4 SHA1 b69c3591ba6d2145fc0a03d7edc4dda62c28f6b0 SHA256 5a0d311143e369ef976ce02a536035da2db7bad008cd11e5e3323e85fa282635
+EBUILD samba-3.3.7.ebuild 7593 RMD160 b7bdd2cf043878df2b4392391f4f47ebf1bb4b48 SHA1 b15a0ef7b58c2f20863ca455f8bfa36ee0de193d SHA256 e9391c54879e636afdff5b505d8a183dbf31169ce3151e6a62474afd5d9048be
 MISC metadata.xml 950 RMD160 4947143536f9776d7dd7f7d6552d624e1f2ac14d SHA1 ef8a8c0c5cd229c88b1f93042ebfbdafaf45deb2 SHA256 b040a13821dbd3f1214b96ed5a808188ef0996161b0ce0cc11de8d8397de960f
--- a/net-fs/samba/samba-3.3.6.ebuild	Fri Jul 24 13:57:01 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,265 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.2.0_rc2.ebuild,v 1.1 2008/06/12 12:10:25 dev-zero Exp $
-
-inherit eutils pam multilib versionator confutils
-
-MY_P=${PN}-${PV/_/}
-
-DESCRIPTION="A suite of SMB and CIFS client/server programs for UNIX"
-HOMEPAGE="http://www.samba.org/"
-SRC_URI="mirror://samba/${MY_P}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE_LINGUAS="linguas_ja linguas_pl"
-IUSE="${IUSE_LINGUAS} acl ads async automount caps cups doc examples ipv6 kernel_linux ldap fam
-	pam quotas readline selinux swat syslog winbind"
-
-RDEPEND="dev-libs/popt
-	dev-libs/iniparser
-	virtual/libiconv
-	acl? ( kernel_linux? ( sys-apps/acl ) )
-	cups? ( net-print/cups )
-	ipv6? ( sys-apps/xinetd )
-	ads? ( virtual/krb5 sys-fs/e2fsprogs )
-	ldap? ( net-nds/openldap )
-	pam? ( virtual/pam )
-	readline? ( sys-libs/readline )
-	selinux? ( sec-policy/selinux-samba )
-	swat? ( sys-apps/xinetd )
-	syslog? ( virtual/logger )
-	fam? ( virtual/fam )
-	caps? ( sys-libs/libcap )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-CONFDIR="${FILESDIR}/config-3.3"
-PRIVATE_DST=/var/lib/samba/private
-
-# Tests are currently broken due to hardcoded paths (due to --with-fhs)
-# The problem is that --without-fhs lets samba use lockdir (which can be changed in smb.conf)
-# which is wrong as well.
-RESTRICT="test"
-
-pkg_setup() {
-	confutils_use_depend_all ads ldap
-}
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}/source"
-
-	# Ok, agreed, this is ugly. But it avoids a patch we
-	# need for every samba version and we don't need autotools
-	sed -i \
-		-e 's|"lib32" ||' \
-		-e 's|if test -d "$i/$l" ;|if test -d "$i/$l" -o -L "$i/$l";|' \
-		configure || die "sed failed"
-
-	rm "${S}/docs/manpages"/{mount,umount}.cifs.8
-
-	sed -i \
-		-e 's|tdbsam|tdbsam:${PRIVATEDIR}/passdb.tdb|' \
-		"${S}/source/script/tests/selftest.sh" || die "sed failed"
-}
-
-src_compile() {
-	cd "${S}/source"
-
-	local myconf
-	local mylangs
-	local mymod_shared
-
-	use winbind && mymod_shared="--with-shared-modules=idmap_rid"
-	if use ldap ; then
-		myconf="${myconf} $(use_with ads)"
-		use winbind && mymod_shared="${mymod_shared},idmap_ad"
-	fi
-
-	[[ ${CHOST} == *-*bsd* ]] && myconf="${myconf} --disable-pie"
-	use hppa && myconf="${myconf} --disable-pie"
-
-	use caps && export ac_cv_header_sys_capability_h=yes || export ac_cv_header_sys_capability_h=no
-
-	# Otherwise we get the whole swat stuff installed
-	if ! use swat ; then
-		sed -i \
-			-e 's/^\(install:.*\)installswat \(.*\)/\1\2/' \
-			Makefile.in || die "sed failed"
-	fi
-
-	econf \
-		--with-fhs \
-		--sysconfdir=/etc/samba \
-		--localstatedir=/var \
-		--with-configdir=/etc/samba \
-		--with-modulesdir=/usr/$(get_libdir)/samba \
-		--with-pammodulesdir=$(getpam_mod_dir) \
-		--with-swatdir=/usr/share/doc/${PF}/swat \
-		--with-piddir=/var/run/samba \
-		--with-lockdir=/var/cache/samba \
-		--with-logfilebase=/var/log/samba \
-		--with-privatedir=${PRIVATE_DST} \
-		--with-libsmbclient \
-		--enable-socket-wrapper \
-		--enable-nss-wrapper \
-		--with-cifsmount=no \
-		$(use_with acl acl-support) \
-		$(use_with async aio-support) \
-		$(use_with automount) \
-		$(use_enable cups) \
-		$(use_enable fam) \
-		$(use_with ads krb5) \
-		$(use_with ads dnsupdate) \
-		$(use_with ldap) \
-		$(use_with pam) $(use_with pam pam_smbpass) \
-		$(use_with quotas) $(use_with quotas sys-quotas) \
-		$(use_with readline) \
-		$(use_with syslog) \
-		$(use_with winbind) \
-		${myconf} ${mylangs} ${mymod_shared} || die "econf failed"
-
-	emake proto || die "emake proto failed"
-	emake everything || die "emake everything failed"
-
-}
-
-src_test() {
-	cd "${S}/source"
-	emake test || die "tests failed"
-}
-
-src_install() {
-	cd "${S}/source"
-
-	emake DESTDIR="${D}" install-everything || die "emake install-everything failed"
-
-	# Extra rpctorture progs
-	local extra_bins="rpctorture"
-	for i in ${extra_bins} ; do
-		[[ -x "${S}/bin/${i}" ]] && dobin "${S}/bin/${i}"
-	done
-
-	# remove .old stuff from /usr/bin:
-	rm -f "${D}"/usr/bin/*.old
-
-	# Removing executable bits from header-files
-	fperms 644 /usr/include/libsmbclient.h
-
-	# Nsswitch extensions. Make link for wins and winbind resolvers
-	if use winbind ; then
-		dolib.so nsswitch/libnss_wins.so
-		dosym libnss_wins.so /usr/$(get_libdir)/libnss_wins.so.2
-		dolib.so nsswitch/libnss_winbind.so
-		dosym libnss_winbind.so /usr/$(get_libdir)/libnss_winbind.so.2
-	fi
-
-	# make the smb backend symlink for cups printing support (bug #133133)
-	if use cups ; then
-		dodir $(cups-config --serverbin)/backend
-		dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
-	fi
-
-	cd "${S}/source"
-
-	# General config files
-	insinto /etc/samba
-	doins "${CONFDIR}"/{smbusers,lmhosts}
-	newins "${CONFDIR}/smb.conf.example-samba3" smb.conf.example
-
-	newpamd "${CONFDIR}/samba.pam" samba
-	use winbind && dopamd "${CONFDIR}/system-auth-winbind"
-	if use swat ; then
-		insinto /etc/xinetd.d
-		newins "${CONFDIR}/swat.xinetd" swat
-	else
-		rm -f "${D}/usr/sbin/swat"
-		rm -f "${D}/usr/share/man/man8/swat.8"
-	fi
-
-	newinitd "${FILESDIR}/samba-init" samba
-	newconfd "${FILESDIR}/samba-conf" samba
-
-	if use ldap ; then
-		insinto /etc/openldap/schema
-		doins "${S}/examples/LDAP/samba.schema"
-	fi
-
-	if use ipv6 ; then
-		insinto /etc/xinetd.d
-		newins "${FILESDIR}/samba-xinetd" smb
-	fi
-
-	# dirs
-	diropts -m0700 ; keepdir "${PRIVATE_DST}"
-	diropts -m1777 ; keepdir /var/spool/samba
-
-	diropts -m0755
-	keepdir /var/{log,run,cache}/samba
-	keepdir /var/lib/samba/{netlogon,profiles}
-	keepdir /var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC,X64,IA64,COLOR}
-	keepdir /usr/$(get_libdir)/samba/{rpc,idmap,auth}
-
-	# docs
-	dodoc "${FILESDIR}/README.gentoo"
-	dodoc "${S}"/{MAINTAINERS,README,Roadmap,WHATSNEW.txt}
-	dodoc "${CONFDIR}/nsswitch.conf-wins"
-	use winbind && dodoc "${CONFDIR}/nsswitch.conf-winbind"
-
-	if use examples ; then
-		insinto /usr/share/doc/${PF}
-		doins -r "${S}/examples/"
-		find "${D}/usr/share/doc/${PF}" -type d -print0 | xargs -0 chmod 755
-		find "${D}/usr/share/doc/${PF}/examples" ! -type d -print0 | xargs -0 chmod 644
-	fi
-
-	if ! use doc ; then
-		if ! use swat ; then
-			rm -rf "${D}/usr/share/doc/${PF}/swat"
-		else
-			rm -rf "${D}/usr/share/doc/${PF}/swat/help"/{guide,howto,devel}
-			rm -rf "${D}/usr/share/doc/${PF}/swat/using_samba"
-		fi
-	fi
-
-}
-
-pkg_preinst() {
-	local PRIVATE_SRC=/etc/samba/private
-	if [[ ! -r "${ROOT}/${PRIVATE_DST}/secrets.tdb" \
-		&& -r "${ROOT}/${PRIVATE_SRC}/secrets.tdb" ]] ; then
-		ebegin "Copying ${ROOT}/${PRIVATE_SRC}/* to ${ROOT}/${PRIVATE_DST}/"
-			mkdir -p "${D}/${PRIVATE_DST}"
-			cp -pPRf "${ROOT}/${PRIVATE_SRC}"/* "${D}/${PRIVATE_DST}/"
-		eend $?
-	fi
-
-	if [[ ! -f "${ROOT}/etc/samba/smb.conf" ]] ; then
-		touch "${D}/etc/samba/smb.conf"
-	fi
-}
-
-pkg_postinst() {
-	if use swat ; then
-		einfo "swat must be enabled by xinetd:"
-		einfo "  change the /etc/xinetd.d/swat configuration"
-	fi
-
-	if use ipv6 ; then
-		einfo "ipv6 support must be enabled by xinetd:"
-		einfo "  change the /etc/xinetd.d/smb configuration"
-	fi
-
-	elog "It is possible to start/stop daemons separately:"
-	elog "  Create a symlink from /etc/init.d/samba.{smbd,nmbd,winbind} to"
-	elog "  /etc/init.d/samba. Calling /etc/init.d/samba directly will start"
-	elog "  the daemons configured in /etc/conf.d/samba"
-
-	elog "The mount/umount.cifs helper applications are not included anymore."
-	elog "Please install net-fs/mount-cifs instead."
-
-	ewarn "If you're upgrading from 3.0.24 or earlier, please make sure to"
-	ewarn "restart your clients to clear any cached information about the server."
-	ewarn "Otherwise they might not be able to connect to the volumes."
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-fs/samba/samba-3.3.7.ebuild	Tue Aug 04 14:41:58 2009 +0200
@@ -0,0 +1,265 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.2.0_rc2.ebuild,v 1.1 2008/06/12 12:10:25 dev-zero Exp $
+
+inherit eutils pam multilib versionator confutils
+
+MY_P=${PN}-${PV/_/}
+
+DESCRIPTION="A suite of SMB and CIFS client/server programs for UNIX"
+HOMEPAGE="http://www.samba.org/"
+SRC_URI="mirror://samba/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE_LINGUAS="linguas_ja linguas_pl"
+IUSE="${IUSE_LINGUAS} acl ads async automount caps cups doc examples ipv6 kernel_linux ldap fam
+	pam quotas readline selinux swat syslog winbind"
+
+RDEPEND="dev-libs/popt
+	dev-libs/iniparser
+	virtual/libiconv
+	acl? ( kernel_linux? ( sys-apps/acl ) )
+	cups? ( net-print/cups )
+	ipv6? ( sys-apps/xinetd )
+	ads? ( virtual/krb5 sys-fs/e2fsprogs )
+	ldap? ( net-nds/openldap )
+	pam? ( virtual/pam )
+	readline? ( sys-libs/readline )
+	selinux? ( sec-policy/selinux-samba )
+	swat? ( sys-apps/xinetd )
+	syslog? ( virtual/logger )
+	fam? ( virtual/fam )
+	caps? ( sys-libs/libcap )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+CONFDIR="${FILESDIR}/config-3.3"
+PRIVATE_DST=/var/lib/samba/private
+
+# Tests are currently broken due to hardcoded paths (due to --with-fhs)
+# The problem is that --without-fhs lets samba use lockdir (which can be changed in smb.conf)
+# which is wrong as well.
+RESTRICT="test"
+
+pkg_setup() {
+	confutils_use_depend_all ads ldap
+}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}/source"
+
+	# Ok, agreed, this is ugly. But it avoids a patch we
+	# need for every samba version and we don't need autotools
+	sed -i \
+		-e 's|"lib32" ||' \
+		-e 's|if test -d "$i/$l" ;|if test -d "$i/$l" -o -L "$i/$l";|' \
+		configure || die "sed failed"
+
+	rm "${S}/docs/manpages"/{mount,umount}.cifs.8
+
+	sed -i \
+		-e 's|tdbsam|tdbsam:${PRIVATEDIR}/passdb.tdb|' \
+		"${S}/source/script/tests/selftest.sh" || die "sed failed"
+}
+
+src_compile() {
+	cd "${S}/source"
+
+	local myconf
+	local mylangs
+	local mymod_shared
+
+	use winbind && mymod_shared="--with-shared-modules=idmap_rid"
+	if use ldap ; then
+		myconf="${myconf} $(use_with ads)"
+		use winbind && mymod_shared="${mymod_shared},idmap_ad"
+	fi
+
+	[[ ${CHOST} == *-*bsd* ]] && myconf="${myconf} --disable-pie"
+	use hppa && myconf="${myconf} --disable-pie"
+
+	use caps && export ac_cv_header_sys_capability_h=yes || export ac_cv_header_sys_capability_h=no
+
+	# Otherwise we get the whole swat stuff installed
+	if ! use swat ; then
+		sed -i \
+			-e 's/^\(install:.*\)installswat \(.*\)/\1\2/' \
+			Makefile.in || die "sed failed"
+	fi
+
+	econf \
+		--with-fhs \
+		--sysconfdir=/etc/samba \
+		--localstatedir=/var \
+		--with-configdir=/etc/samba \
+		--with-modulesdir=/usr/$(get_libdir)/samba \
+		--with-pammodulesdir=$(getpam_mod_dir) \
+		--with-swatdir=/usr/share/doc/${PF}/swat \
+		--with-piddir=/var/run/samba \
+		--with-lockdir=/var/cache/samba \
+		--with-logfilebase=/var/log/samba \
+		--with-privatedir=${PRIVATE_DST} \
+		--with-libsmbclient \
+		--enable-socket-wrapper \
+		--enable-nss-wrapper \
+		--with-cifsmount=no \
+		$(use_with acl acl-support) \
+		$(use_with async aio-support) \
+		$(use_with automount) \
+		$(use_enable cups) \
+		$(use_enable fam) \
+		$(use_with ads krb5) \
+		$(use_with ads dnsupdate) \
+		$(use_with ldap) \
+		$(use_with pam) $(use_with pam pam_smbpass) \
+		$(use_with quotas) $(use_with quotas sys-quotas) \
+		$(use_with readline) \
+		$(use_with syslog) \
+		$(use_with winbind) \
+		${myconf} ${mylangs} ${mymod_shared} || die "econf failed"
+
+	emake proto || die "emake proto failed"
+	emake everything || die "emake everything failed"
+
+}
+
+src_test() {
+	cd "${S}/source"
+	emake test || die "tests failed"
+}
+
+src_install() {
+	cd "${S}/source"
+
+	emake DESTDIR="${D}" install-everything || die "emake install-everything failed"
+
+	# Extra rpctorture progs
+	local extra_bins="rpctorture"
+	for i in ${extra_bins} ; do
+		[[ -x "${S}/bin/${i}" ]] && dobin "${S}/bin/${i}"
+	done
+
+	# remove .old stuff from /usr/bin:
+	rm -f "${D}"/usr/bin/*.old
+
+	# Removing executable bits from header-files
+	fperms 644 /usr/include/libsmbclient.h
+
+	# Nsswitch extensions. Make link for wins and winbind resolvers
+	if use winbind ; then
+		dolib.so nsswitch/libnss_wins.so
+		dosym libnss_wins.so /usr/$(get_libdir)/libnss_wins.so.2
+		dolib.so nsswitch/libnss_winbind.so
+		dosym libnss_winbind.so /usr/$(get_libdir)/libnss_winbind.so.2
+	fi
+
+	# make the smb backend symlink for cups printing support (bug #133133)
+	if use cups ; then
+		dodir $(cups-config --serverbin)/backend
+		dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
+	fi
+
+	cd "${S}/source"
+
+	# General config files
+	insinto /etc/samba
+	doins "${CONFDIR}"/{smbusers,lmhosts}
+	newins "${CONFDIR}/smb.conf.example-samba3" smb.conf.example
+
+	newpamd "${CONFDIR}/samba.pam" samba
+	use winbind && dopamd "${CONFDIR}/system-auth-winbind"
+	if use swat ; then
+		insinto /etc/xinetd.d
+		newins "${CONFDIR}/swat.xinetd" swat
+	else
+		rm -f "${D}/usr/sbin/swat"
+		rm -f "${D}/usr/share/man/man8/swat.8"
+	fi
+
+	newinitd "${FILESDIR}/samba-init" samba
+	newconfd "${FILESDIR}/samba-conf" samba
+
+	if use ldap ; then
+		insinto /etc/openldap/schema
+		doins "${S}/examples/LDAP/samba.schema"
+	fi
+
+	if use ipv6 ; then
+		insinto /etc/xinetd.d
+		newins "${FILESDIR}/samba-xinetd" smb
+	fi
+
+	# dirs
+	diropts -m0700 ; keepdir "${PRIVATE_DST}"
+	diropts -m1777 ; keepdir /var/spool/samba
+
+	diropts -m0755
+	keepdir /var/{log,run,cache}/samba
+	keepdir /var/lib/samba/{netlogon,profiles}
+	keepdir /var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC,X64,IA64,COLOR}
+	keepdir /usr/$(get_libdir)/samba/{rpc,idmap,auth}
+
+	# docs
+	dodoc "${FILESDIR}/README.gentoo"
+	dodoc "${S}"/{MAINTAINERS,README,Roadmap,WHATSNEW.txt}
+	dodoc "${CONFDIR}/nsswitch.conf-wins"
+	use winbind && dodoc "${CONFDIR}/nsswitch.conf-winbind"
+
+	if use examples ; then
+		insinto /usr/share/doc/${PF}
+		doins -r "${S}/examples/"
+		find "${D}/usr/share/doc/${PF}" -type d -print0 | xargs -0 chmod 755
+		find "${D}/usr/share/doc/${PF}/examples" ! -type d -print0 | xargs -0 chmod 644
+	fi
+
+	if ! use doc ; then
+		if ! use swat ; then
+			rm -rf "${D}/usr/share/doc/${PF}/swat"
+		else
+			rm -rf "${D}/usr/share/doc/${PF}/swat/help"/{guide,howto,devel}
+			rm -rf "${D}/usr/share/doc/${PF}/swat/using_samba"
+		fi
+	fi
+
+}
+
+pkg_preinst() {
+	local PRIVATE_SRC=/etc/samba/private
+	if [[ ! -r "${ROOT}/${PRIVATE_DST}/secrets.tdb" \
+		&& -r "${ROOT}/${PRIVATE_SRC}/secrets.tdb" ]] ; then
+		ebegin "Copying ${ROOT}/${PRIVATE_SRC}/* to ${ROOT}/${PRIVATE_DST}/"
+			mkdir -p "${D}/${PRIVATE_DST}"
+			cp -pPRf "${ROOT}/${PRIVATE_SRC}"/* "${D}/${PRIVATE_DST}/"
+		eend $?
+	fi
+
+	if [[ ! -f "${ROOT}/etc/samba/smb.conf" ]] ; then
+		touch "${D}/etc/samba/smb.conf"
+	fi
+}
+
+pkg_postinst() {
+	if use swat ; then
+		einfo "swat must be enabled by xinetd:"
+		einfo "  change the /etc/xinetd.d/swat configuration"
+	fi
+
+	if use ipv6 ; then
+		einfo "ipv6 support must be enabled by xinetd:"
+		einfo "  change the /etc/xinetd.d/smb configuration"
+	fi
+
+	elog "It is possible to start/stop daemons separately:"
+	elog "  Create a symlink from /etc/init.d/samba.{smbd,nmbd,winbind} to"
+	elog "  /etc/init.d/samba. Calling /etc/init.d/samba directly will start"
+	elog "  the daemons configured in /etc/conf.d/samba"
+
+	elog "The mount/umount.cifs helper applications are not included anymore."
+	elog "Please install net-fs/mount-cifs instead."
+
+	ewarn "If you're upgrading from 3.0.24 or earlier, please make sure to"
+	ewarn "restart your clients to clear any cached information about the server."
+	ewarn "Otherwise they might not be able to connect to the volumes."
+}