changeset 152:2cb495e793ae

add graphicsmagick to replace imagemagick
author holger
date Tue, 11 Aug 2009 15:07:12 +0200
parents 2c475c91786e
children c494760eb51c
files media-gfx/graphicsmagick/Manifest media-gfx/graphicsmagick/graphicsmagick-1.3.6.ebuild sys-fs/ntfs3g/Manifest sys-fs/ntfs3g/ntfs3g-1.5130.ebuild sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild
diffstat 5 files changed, 158 insertions(+), 55 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-gfx/graphicsmagick/Manifest	Tue Aug 11 15:07:12 2009 +0200
@@ -0,0 +1,2 @@
+DIST GraphicsMagick-1.3.6.tar.bz2 6556163 RMD160 9c20aeecd4e351fcdfb695845076c89647e991bf SHA1 fd6bbc6682a2ee5a64380991f1fe151d3e8a6d54 SHA256 c2fcef43cf4018c19880e0302f234dc45eb31d79d254df8b236781b161755712
+EBUILD graphicsmagick-1.3.6.ebuild 2557 RMD160 134523d4abe69b21c2a0d63030d8dd67a742ee0b SHA1 ef9c110c5b645fe477bf7649f47095b5e37c36e6 SHA256 d05786fc02ff248cb5eff30edd5f3e3c20c6d5b8d50706d9c70694e612db259a
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.6.ebuild	Tue Aug 11 15:07:12 2009 +0200
@@ -0,0 +1,101 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit flag-o-matic perl-app
+
+MY_P=${P/graphicsm/GraphicsM}
+
+DESCRIPTION="A collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.graphicsmagick.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 cxx debug fpx imagemagick jbig +jpeg +jpeg2k lcms openmp
+	perl +png q16 q32 +svg +threads tiff +truetype X wmf zlib"
+
+DEPEND="bzip2? ( app-arch/bzip2 )
+	fpx? ( media-libs/libfpx )
+	virtual/ghostscript
+	jbig? ( media-libs/jbigkit )
+	jpeg? ( media-libs/jpeg )
+	jpeg2k? ( >=media-libs/jasper-1.701.0 )
+	lcms? ( media-libs/lcms )
+	media-video/mpeg2vidcodec
+	openmp? ( sys-devel/gcc[openmp] )
+	perl? ( dev-lang/perl )
+	png? ( media-libs/libpng )
+	svg? ( dev-libs/libxml2 )
+	tiff? ( >=media-libs/tiff-3.8.2 )
+	truetype? ( >=media-libs/freetype-2.0 )
+	wmf? ( media-libs/libwmf )
+	X? ( x11-libs/libXext
+		x11-libs/libSM
+		x11-libs/libX11
+		x11-libs/libICE )
+	imagemagick? ( !media-gfx/imagemagick )"
+RDEPEND=${DEPEND}
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+	local quantumDepth="--with-quantum-depth="
+	if use q16 ; then
+		quantumDepth="${quantumDepth}16"
+	elif use q32 ; then
+		quantumDepth="${quantumDepth}32"
+	else
+		quantumDepth="${quantumDepth}8"
+	fi
+
+	use debug && filter-flags -fomit-frame-pointer
+
+	econf \
+		${quantumDepth} \
+		$( use_enable imagemagick magick-compat ) \
+		$( use_enable openmp ) \
+		$( use_with bzip2 bzlib ) \
+		$( use_with fpx ) \
+		$( use_with jbig ) \
+		$( use_with jpeg ) \
+		$( use_with jpeg2k jp2 ) \
+		$( use_with lcms ) \
+		$( use_with cxx magick-plus-plus ) \
+		$( use_with perl ) \
+		$( use_with png ) \
+		$( use_with tiff ) \
+		$( use_with truetype ttf ) \
+		$( use_with X x ) \
+		$( use_with svg xml ) \
+		$( use_with wmf ) \
+		$( use_with zlib ) \
+		$( use_with threads ) \
+		$( use_enable debug ccmalloc ) \
+		$( use_enable debug prof ) \
+		$( use_enable debug gcov ) \
+		--disable-gprof \
+		--enable-largefile \
+		--without-included-ltdl \
+		--without-gslib \
+		--without-dps \
+		--without-umem \
+		--without-trio \
+		--with-modules \
+		--enable-shared
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "Installation failed"
+	dodoc README.txt ChangeLog* || die "dodoc failed."
+
+	# Fix perllocal.pod file collision
+	use perl && fixlocalpod
+}
+
+pkg_postinst() {
+	elog "For RAW image suport please install media-gfx/dcraw."
+	elog "To read gnuplot files please install sci-visualization/gnuplot."
+}
--- a/sys-fs/ntfs3g/Manifest	Tue Aug 04 14:41:58 2009 +0200
+++ b/sys-fs/ntfs3g/Manifest	Tue Aug 11 15:07:12 2009 +0200
@@ -1,4 +1,4 @@
 AUX 10-ntfs3g.fdi 397 RMD160 a09440a0d239db40ce7c6cada0008e425a0a5dc7 SHA1 d26af4f1dcdfad6da384b0e706c79a629fa893dd SHA256 bceb8474647e9dd8a1740d3d3af559cbd9f5ad428f335606f44f87b17c712de7
-DIST ntfs-3g-1.5130.tgz 649883 RMD160 173b1c7e3a94d440ecaa19d97980ba6f3228e33e SHA1 02b7a874b02827665c97123c6335e1d856054c42 SHA256 a456973a4b44c8fa1b63214425edfd1a72fd7b26ab40d25a4372e2a4f3ac4057
-EBUILD ntfs3g-1.5130.ebuild 1278 RMD160 cb81bae446250f7f88ee77aa51c6da7201980d95 SHA1 65789307d54ec097e4eab738fb6c757fddb9fb40 SHA256 13e5ad5cc6eb5be95bccc05b4a9747ea9cf38ee854564e5cf8009c7756d5f476
+DIST ntfs-3g-2009.4.4.tgz 652496 RMD160 d11b452794dc454396019beacd5f98faa757211f SHA1 a8e54d38e8cae1cdd1178bbbb42a1e5670ae7089 SHA256 bcd39ebe90541f512e605b62911f14f6107239c4ff032d56d5da3dc3c05e0d0f
+EBUILD ntfs3g-2009.4.4.ebuild 1297 RMD160 af3c7657045cb323c6530edef2a834d887ba80ad SHA1 8b503ca4f4cd65156bad1e921166f9f504b5640f SHA256 80aaf29d324c10e0ce311f295765efe504b296d13971820fbb6f354b5f7f38a8
 MISC metadata.xml 641 RMD160 361ae848a3012a236c512a5cfc71cc96026ba072 SHA1 9cc731cc7093ad04c8a3199948f24b2c5ff2cadb SHA256 bb0e59a4fde05b0fbad22547a263d7ef98bb5809fd00bf14c0d4d2c89cab05ed
--- a/sys-fs/ntfs3g/ntfs3g-1.5130.ebuild	Tue Aug 04 14:41:58 2009 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.5012.ebuild,v 1.1 2008/10/23 14:23:59 chutzpah Exp $
-
-MY_PN="${PN/3g/-3g}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
-HOMEPAGE="http://www.ntfs-3g.org"
-SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug hal suid"
-
-RDEPEND="hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
-	econf \
-		--docdir="/usr/share/doc/${PF}" \
-		--enable-ldscript \
-		--disable-ldconfig \
-		$(use_enable debug)
-	emake || die "emake failed"
-}
-
-src_install() {
-	emake DESTDIR="${D}" install || die "install failed"
-
-	prepalldocs
-	dodoc AUTHORS ChangeLog CREDITS
-
-	use suid && fperms u+s "/bin/${MY_PN}"
-
-	if use hal; then
-		insinto /etc/hal/fdi/policy/
-		doins "${FILESDIR}/10-ntfs3g.fdi"
-	fi
-}
-
-pkg_postinst() {
-	if use suid; then
-		ewarn
-		ewarn "You have chosen to install ${PN} with the binary setuid root. This"
-		ewarn "means that if there any undetected vulnerabilities in the binary,"
-		ewarn "then local users may be able to gain root access on your machine."
-		ewarn
-	fi
-}
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild	Tue Aug 11 15:07:12 2009 +0200
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2009.3.8.ebuild,v 1.4 2009/08/02 13:29:02 maekke Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
+IUSE="debug hal suid"
+
+RDEPEND="hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+	econf \
+		--docdir="/usr/share/doc/${PF}" \
+		--enable-ldscript \
+		--disable-ldconfig \
+		$(use_enable debug)
+	emake || die "emake failed"
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die "install failed"
+
+	prepalldocs
+	dodoc AUTHORS ChangeLog CREDITS
+
+	use suid && fperms u+s "/bin/${MY_PN}"
+
+	if use hal; then
+		insinto /etc/hal/fdi/policy/
+		newins "${FILESDIR}/10-ntfs3g.fdi.2009" "10-ntfs3g.fdi"
+	fi
+}
+
+pkg_postinst() {
+	if use suid; then
+		ewarn
+		ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+		ewarn "means that if there any undetected vulnerabilities in the binary,"
+		ewarn "then local users may be able to gain root access on your machine."
+		ewarn
+	fi
+}