changeset 121:30d6ee53317e

bump mercurial to 1.2.1
author holger@hoho.dyndns.org
date Sat, 21 Mar 2009 09:50:37 +0100
parents 17e88fb0f6f2
children 82e977cb0a48
files dev-util/mercurial/Manifest dev-util/mercurial/mercurial-1.2.1.ebuild dev-util/mercurial/mercurial-1.2.ebuild
diffstat 3 files changed, 120 insertions(+), 120 deletions(-) [+]
line wrap: on
line diff
--- a/dev-util/mercurial/Manifest	Fri Mar 20 12:50:28 2009 +0100
+++ b/dev-util/mercurial/Manifest	Sat Mar 21 09:50:37 2009 +0100
@@ -1,4 +1,4 @@
 AUX 70mercurial-gentoo.el 76 RMD160 1891ab510adb464211b4cc35c5b6e4b149da79fa SHA1 72eb35d2bf86fa8f806acfbc823b88fc5188741b SHA256 c215746e4a5375569808c6aa6ddabe08e82d33d744128179be3142d9cd53a5ab
-DIST mercurial-1.2.tar.gz 1266559 RMD160 8625517941f64a636f0b8503891463fe16eda8ef SHA1 c6590f6b833cfed22c04aae34b7060fd3372e86e SHA256 d687a342bc789c14e48d8c2fee3c8a6e4d1ac7f5b4dff89b0cf59145ee8353ed
-EBUILD mercurial-1.2.ebuild 3226 RMD160 743d444c471c607972c0cedb0da2599574b6672a SHA1 a29c432f1335a05cdf26aba60ccbb62e17540f5f SHA256 0f1b83d61da1f559d97d934c7c21601015cb8a622ece49344af3bc0294cca507
+DIST mercurial-1.2.1.tar.gz 1269393 RMD160 37c94e5ef9cdc639fe23622ddaf97b2230ec2216 SHA1 f40282bbb17fedb08b16aa7a4eeb1da7b6a6f1cb SHA256 03187464bccfbd82b78d5c55d708447181745085a62f491a206f5143376eb47e
+EBUILD mercurial-1.2.1.ebuild 3226 RMD160 743d444c471c607972c0cedb0da2599574b6672a SHA1 a29c432f1335a05cdf26aba60ccbb62e17540f5f SHA256 0f1b83d61da1f559d97d934c7c21601015cb8a622ece49344af3bc0294cca507
 MISC metadata.xml 645 RMD160 2a33b3987960796da78558e671c4e5e0c6f10241 SHA1 6cd04e19dc7796b53afe98a9831e128c4c96f3ca SHA256 e0b05e42345698eda32c513e3a8f14d8bf42d5344dcd804b1f2234da327524e2
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dev-util/mercurial/mercurial-1.2.1.ebuild	Sat Mar 21 09:50:37 2009 +0100
@@ -0,0 +1,118 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-1.0.2.ebuild,v 1.7 2008/10/17 08:04:41 aballier Exp $
+
+inherit bash-completion elisp-common flag-o-matic eutils distutils
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://www.selenic.com/mercurial/"
+SRC_URI="http://www.selenic.com/mercurial/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="bugzilla emacs gpg test zsh-completion"
+
+CDEPEND=">=dev-lang/python-2.3"
+RDEPEND="${CDEPEND}
+	bugzilla? ( dev-python/mysql-python )
+	gpg? ( app-crypt/gnupg )
+	zsh-completion? ( app-shells/zsh )"
+DEPEND="${CDEPEND}
+	emacs? ( virtual/emacs )
+	test? ( app-arch/unzip
+		dev-python/pygments )"
+
+PYTHON_MODNAME="${PN} hgext"
+SITEFILE="70${PN}-gentoo.el"
+
+src_compile() {
+	filter-flags -ftracer -ftree-vectorize
+
+	distutils_src_compile
+
+	if use emacs; then
+		cd "${S}"/contrib
+		elisp-compile mercurial.el || die "elisp-compile failed!"
+	fi
+
+	rm -rf contrib/{win32,macosx}
+}
+
+src_install() {
+	distutils_src_install
+
+	dobashcompletion contrib/bash_completion ${PN}
+
+	if use zsh-completion ; then
+		insinto /usr/share/zsh/site-functions
+		newins contrib/zsh_completion _hg
+	fi
+
+	rm -f doc/*.?.txt
+	dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
+	cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
+
+	dobin contrib/hgk
+	dobin contrib/hg-relink
+	dobin contrib/hg-ssh
+
+	rm -f contrib/hgk contrib/hg-relink contrib/hg-ssh
+
+	rm -f contrib/bash_completion
+	cp -r contrib "${D}"/usr/share/doc/${PF}/
+	doman doc/*.?
+
+	cat > "${T}/80mercurial" <<-EOF
+HG=/usr/bin/hg
+EOF
+	doenvd "${T}/80mercurial"
+
+	if use emacs; then
+		elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+	fi
+}
+
+src_test() {
+	local testdir="${T}/tests"
+	mkdir -p -m1777 "${testdir}" || die
+	cd "${S}/tests/"
+	rm -f *svn*		# Subversion tests fail with 1.5
+	rm -f test-convert-baz*		# GNU Arch baz
+	rm -f test-convert-cvs*		# CVS
+	rm -f test-convert-darcs*	# Darcs
+	rm -f test-convert-git*		# git
+	rm -f test-convert-mtn*		# monotone
+	rm -f test-convert-tla*		# GNU Arch tla
+	rm -f test-doctest*		# doctest always fails with python 2.5.x
+	if ! has userpriv ${FEATURES}; then
+		einfo "Removing tests which require user privileges to succeed"
+		rm -f test-command-template	# Test is broken when run as root
+		rm -f test-convert			# Test is broken when run as root
+		rm -f test-lock-badness		# Test is broken when run as root
+		rm -f test-permissions		# Test is broken when run as root
+		rm -f test-pull-permission	# Test is broken when run as root
+	fi
+	einfo "Running Mercurial tests ..."
+	python run-tests.py --tmpdir="${testdir}" || die "test failed"
+}
+
+pkg_postinst() {
+	distutils_pkg_postinst
+	use emacs && elisp-site-regen
+	bash-completion_pkg_postinst
+
+	elog "If you want to convert repositories from other tools using convert"
+	elog "extension please install correct tool:"
+	elog "  dev-util/cvs"
+	elog "  dev-util/darcs"
+	elog "  dev-util/git"
+	elog "  dev-util/monotone"
+	elog "  dev-util/subversion"
+}
+
+pkg_postrm() {
+	distutils_pkg_postrm
+	use emacs && elisp-site-regen
+}
--- a/dev-util/mercurial/mercurial-1.2.ebuild	Fri Mar 20 12:50:28 2009 +0100
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,118 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-1.0.2.ebuild,v 1.7 2008/10/17 08:04:41 aballier Exp $
-
-inherit bash-completion elisp-common flag-o-matic eutils distutils
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://www.selenic.com/mercurial/"
-SRC_URI="http://www.selenic.com/mercurial/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="bugzilla emacs gpg test zsh-completion"
-
-CDEPEND=">=dev-lang/python-2.3"
-RDEPEND="${CDEPEND}
-	bugzilla? ( dev-python/mysql-python )
-	gpg? ( app-crypt/gnupg )
-	zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
-	emacs? ( virtual/emacs )
-	test? ( app-arch/unzip
-		dev-python/pygments )"
-
-PYTHON_MODNAME="${PN} hgext"
-SITEFILE="70${PN}-gentoo.el"
-
-src_compile() {
-	filter-flags -ftracer -ftree-vectorize
-
-	distutils_src_compile
-
-	if use emacs; then
-		cd "${S}"/contrib
-		elisp-compile mercurial.el || die "elisp-compile failed!"
-	fi
-
-	rm -rf contrib/{win32,macosx}
-}
-
-src_install() {
-	distutils_src_install
-
-	dobashcompletion contrib/bash_completion ${PN}
-
-	if use zsh-completion ; then
-		insinto /usr/share/zsh/site-functions
-		newins contrib/zsh_completion _hg
-	fi
-
-	rm -f doc/*.?.txt
-	dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
-	cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
-
-	dobin contrib/hgk
-	dobin contrib/hg-relink
-	dobin contrib/hg-ssh
-
-	rm -f contrib/hgk contrib/hg-relink contrib/hg-ssh
-
-	rm -f contrib/bash_completion
-	cp -r contrib "${D}"/usr/share/doc/${PF}/
-	doman doc/*.?
-
-	cat > "${T}/80mercurial" <<-EOF
-HG=/usr/bin/hg
-EOF
-	doenvd "${T}/80mercurial"
-
-	if use emacs; then
-		elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
-		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
-	fi
-}
-
-src_test() {
-	local testdir="${T}/tests"
-	mkdir -p -m1777 "${testdir}" || die
-	cd "${S}/tests/"
-	rm -f *svn*		# Subversion tests fail with 1.5
-	rm -f test-convert-baz*		# GNU Arch baz
-	rm -f test-convert-cvs*		# CVS
-	rm -f test-convert-darcs*	# Darcs
-	rm -f test-convert-git*		# git
-	rm -f test-convert-mtn*		# monotone
-	rm -f test-convert-tla*		# GNU Arch tla
-	rm -f test-doctest*		# doctest always fails with python 2.5.x
-	if ! has userpriv ${FEATURES}; then
-		einfo "Removing tests which require user privileges to succeed"
-		rm -f test-command-template	# Test is broken when run as root
-		rm -f test-convert			# Test is broken when run as root
-		rm -f test-lock-badness		# Test is broken when run as root
-		rm -f test-permissions		# Test is broken when run as root
-		rm -f test-pull-permission	# Test is broken when run as root
-	fi
-	einfo "Running Mercurial tests ..."
-	python run-tests.py --tmpdir="${testdir}" || die "test failed"
-}
-
-pkg_postinst() {
-	distutils_pkg_postinst
-	use emacs && elisp-site-regen
-	bash-completion_pkg_postinst
-
-	elog "If you want to convert repositories from other tools using convert"
-	elog "extension please install correct tool:"
-	elog "  dev-util/cvs"
-	elog "  dev-util/darcs"
-	elog "  dev-util/git"
-	elog "  dev-util/monotone"
-	elog "  dev-util/subversion"
-}
-
-pkg_postrm() {
-	distutils_pkg_postrm
-	use emacs && elisp-site-regen
-}