changeset 382:31a33e308598

add build support for selected plugins
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 12 Mar 2015 04:16:10 +0100
parents cf8e0286cc7d
children 82fc17734d23 d790e87dc863
files net-im/psi-plus/Manifest net-im/psi-plus/psi-plus-0.16.449.ebuild
diffstat 2 files changed, 67 insertions(+), 3 deletions(-) [+]
line wrap: on
line diff
--- a/net-im/psi-plus/Manifest	Wed Mar 11 21:36:01 2015 +0100
+++ b/net-im/psi-plus/Manifest	Thu Mar 12 04:16:10 2015 +0100
@@ -1,2 +1,2 @@
 DIST 0.16.449.tar.gz 8277518 SHA256 3c3e0f464dc342f6803adca0294b6943d19113799c678bf58233a6dc59783e68 SHA512 8c1053e573ac255e0654fad430a065c9d67144a775e3cde47f0a94b07d642816630a2cee9e5e8e62da0f1f4d70c495289b525b40cbc8eea629fa316f3928f365 WHIRLPOOL cc304c34b639cd1c7d8a469f877612422e5e87153b8d21f51622ac6537d562ce3733b751264533bf24d2e215b73c3c5f51bf8d57d0068bf9624bde658ea50836
-EBUILD psi-plus-0.16.449.ebuild 1756 SHA256 b8046cb2a37d759843f2bd7395d6797a0ab6b93cddd27b35b29c7608e60abbaa SHA512 eb29176958ab3a664e8aa22838b9f608494d74e424e1c3cb11aa478658cc5dcec902083cb1a24249a1b6718262b331b836d27f0f0753410891d300936db7f9ea WHIRLPOOL 216893b126699b57d42dc0931f7daaa011aea8c2b52d43d8c566289be259e152e327ad0adb87135031f6bd891834f090f92dfe229a9064d3909496ddedf8eb3a
+EBUILD psi-plus-0.16.449.ebuild 2966 SHA256 5e7331db84666a4625faa78ca36fe70356c9095fbe31acd7410e638b8ca0c707 SHA512 c31e89d6b6049c0224ab6882983dde0171505ecde8e2435bd022a6c4a8f9e489e79998f5b2d2d9702c78b51e4e98d4ef2374263d6ee0dc8da220b944da3157c5 WHIRLPOOL 19e29f9de540fbadb3a186c0599506a4f34b98a53fde56d0a4a8c8bb24c787237876cff8e50766374f0900e2f5b82b2c832bb042e05a8cbdd0eb1fe1046be985
--- a/net-im/psi-plus/psi-plus-0.16.449.ebuild	Wed Mar 11 21:36:01 2015 +0100
+++ b/net-im/psi-plus/psi-plus-0.16.449.ebuild	Thu Mar 12 04:16:10 2015 +0100
@@ -12,7 +12,7 @@
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="crypt dbus debug doc jingle plugins spell ssl xscreensaver whiteboarding"
+IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding"
 #RESTRICT="test"
 
 RDEPEND="app-arch/unzip
@@ -32,7 +32,8 @@
 PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
 	jingle? ( net-im/psimedia
 		app-crypt/qca:2[openssl] )
-	ssl? ( app-crypt/qca:2[openssl] )"
+	ssl? ( app-crypt/qca:2[openssl] )
+	otrplugin? ( net-libs/libotr app-text/htmltidy )"
 
 src_prepare() {
 	epatch_user
@@ -59,6 +60,69 @@
 	#[[ ! -f Makefile ]] && die "configure failed"
 }
 
+src_compile() {
+	emake || die "emake failed"
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+	
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+		qmake
+		make
+		cd ../../../..
+	fi
+}
+
+src_install() {
+	emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+	dodoc README TODO ChangeLog
+	
+	if use autoreplyplugin; then
+		cd src/plugins/generic/autoreplyplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libautoreplyplugin.so
+
+		cd ../../../..
+	fi
+
+	if use otrplugin; then
+		cd src/plugins/generic/otrplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libotrplugin.so
+
+		cd ../../../..
+	fi
+
+	if use watcherplugin; then
+		cd src/plugins/generic/watcherplugin
+
+		local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
+		dodir "${plugindir}"
+		insinto "${plugindir}"
+		doins libwatcherplugin.so
+
+		cd ../../../..
+	fi
+}
+
 pkg_preinst() {
 	gnome2_icon_savelist
 }