changeset 37:3593ba11bb06

erlang-12.2.3 is in portage
author holger@hoho.dyndns.org
date Fri, 13 Jun 2008 23:43:34 +0200
parents dd26ef08b731
children cced8319ae11 e30a8e5e8bfe
files dev-lang/erlang/Manifest dev-lang/erlang/erlang-12.2.3.ebuild dev-lang/erlang/files/50erlang-gentoo.el dev-lang/erlang/files/erlang-12.2.3-glibc28.patch
diffstat 4 files changed, 0 insertions(+), 181 deletions(-) [+]
line wrap: on
line diff
--- a/dev-lang/erlang/Manifest	Fri Jun 13 16:59:11 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,6 +0,0 @@
-AUX 50erlang-gentoo.el 134 RMD160 a453ad18f47d20e5ea5ecd1f4e4054d00eab5c35 SHA1 7c17979f533654ef05bbfcc8ae30554e7843923b SHA256 97e1da82cae31a554134d7370739520e4c67b2544e5a13f887651a62e710b4d4
-AUX erlang-12.2.3-glibc28.patch 431 RMD160 0f776b37e3d072f3a8dca72f5eb1cd0893ae522f SHA1 12bdfe823e9bae3ac40d2ee8a951b183b4b85ac8 SHA256 628038216ff9f66aad5100fa8663bc4ca229b33bd9ba952b95c64b43af1635d6
-DIST otp_doc_html_R12B-3.tar.gz 5655205 RMD160 8295d4e94952bad6458f2038415c474e687631cb SHA1 194003607113c84aef5b5daad7ca8b8901d1d80a SHA256 4690829f270a40d6c1849a34e9854ba4f55e1ec1a1e91dbc09e6a0a0a7228005
-DIST otp_doc_man_R12B-3.tar.gz 809746 RMD160 7e0c27391f42b1e58c7bb1472594e9fe6f7ac414 SHA1 8ea4c9fa7d941c339c73bb417f88ee939d6989eb SHA256 08e3ed5a285eabe94fef6726bd591e02c42a8425ddcdb6a6d3f38f4a2d517e62
-DIST otp_src_R12B-3.tar.gz 42195557 RMD160 e7b5da985b939e51ef4e2d19fb96cff1781ce263 SHA1 ea5f202cc35ed6ef2796727b95d62c9bbe6ad5e5 SHA256 a8ed977d468454ca8d849ee5fa08ac3d521d76f23649bef531b76bdfa73f8eb2
-EBUILD erlang-12.2.3.ebuild 4780 RMD160 c4c1e8e8cf9b452e609fa0ca720cb44f105127cc SHA1 9228e1590d644ec42a64a79bbee447a6c4c93322 SHA256 5845cf3c7a1048a4765ced8e18b8aebfd1c696f100be168f8737bf558e322330
--- a/dev-lang/erlang/erlang-12.2.3.ebuild	Fri Jun 13 16:59:11 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,159 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.2.ebuild,v 1.9 2008/05/28 19:47:35 pva Exp $
-
-inherit autotools elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
-	doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
-		http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc sctp smp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
-	ssl? ( >=dev-libs/openssl-0.9.7d )
-	emacs? ( virtual/emacs )
-	java? ( >=virtual/jdk-1.2 )
-	odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
-	sctp? ( net-misc/lksctp-tools )
-	tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50erlang-gentoo.el
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-
-	use odbc || sed -i 's: odbc : :' lib/Makefile
-
-	# fix builds with glibc-2.8, bug 226063
-	epatch "${FILESDIR}"/${P}-glibc28.patch
-
-	# make sure we only link ssl dynamically
-	# will not be integrated by upstream for various reasons
-	sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
-
-	if use hipe; then
-		ewarn
-		ewarn "You enabled High performance Erlang. Be aware that this extension"
-		ewarn "can break the compilation in many ways, especially on hardened systems."
-		ewarn "Don't cry, don't file bugs, just disable it! If you have fix, tell us."
-		ewarn
-	fi
-	eautoreconf
-}
-
-src_compile() {
-	use java || export JAVAC=false
-
-	econf \
-		--enable-threads \
-		$(use_enable hipe) \
-		$(use_with ssl) \
-		$(use_enable sctp) \
-		$(use_enable kpoll kernel-poll) \
-		$(use_enable smp smp-support) \
-		|| die "econf failed"
-	emake -j1 || die "emake failed"
-
-	if use emacs ; then
-		pushd lib/tools/emacs
-		elisp-compile *.el
-		popd
-	fi
-}
-
-extract_version() {
-	sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
-	local ERL_LIBDIR=/usr/$(get_libdir)/erlang
-	local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
-	local ERL_ERTS_VER=$(extract_version erts VSN)
-
-	emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
-	dodoc AUTHORS README
-
-	dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
-	dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
-	dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
-	dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
-	dosym \
-		"${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
-		/usr/bin/erl_call
-	dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
-	## Remove ${D} from the following files
-	dosed "${ERL_LIBDIR}/bin/erl"
-	dosed "${ERL_LIBDIR}/bin/start"
-	grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
-	## Clean up the no longer needed files
-	rm "${D}/${ERL_LIBDIR}/Install"
-
-	if use doc ; then
-		for i in "${WORKDIR}"/man/man* ; do
-			dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
-		done
-		for file in "${WORKDIR}"/man/man*/*.[1-9]; do
-			# Man page processing tools expect a capitalized "SEE ALSO" section
-			# header, has been reported upstream, should be fixed in R12
-			sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
-			# doman sucks so we can't use it
-			cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
-		done
-		# extend MANPATH, so the normal man command can find it
-		# see bug 189639
-		dodir /etc/env.d/
-		echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
-		dohtml -A README,erl,hrl,c,h,kwc,info -r \
-			"${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
-	fi
-
-	if use emacs ; then
-		pushd "${S}"
-		elisp-install erlang lib/tools/emacs/*.{el,elc}
-		elisp-site-file-install "${FILESDIR}"/${SITEFILE}
-		popd
-	fi
-
-	# prepare erl for SMP, fixes bug #188112
-	use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
-		"${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
-	use emacs && elisp-site-regen
-	elog
-	elog "If you need a symlink to one of Erlang's binaries,"
-	elog "please open a bug on http://bugs.gentoo.org/"
-	elog
-	elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
-	elog
-}
-
-pkg_postrm() {
-	use emacs && elisp-site-regen
-}
--- a/dev-lang/erlang/files/50erlang-gentoo.el	Fri Jun 13 16:59:11 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,5 +0,0 @@
-;;; erlang site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-(require 'erlang-start)
-(setq erlang-root-dir "/usr/share")
--- a/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch	Fri Jun 13 16:59:11 2008 +0200
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,11 +0,0 @@
---- erts/emulator/hipe/hipe_x86_signal.c	2008-06-12 14:17:48.831373565 +0200
-+++ erts/emulator/hipe/hipe_x86_signal_ok.c	2008-06-12 14:43:05.132064804 +0200
-@@ -34,7 +34,7 @@
- #endif
- #include "hipe_signal.h"
- 
--#if __GLIBC__ == 2 && (__GLIBC_MINOR__ >= 3 && __GLIBC_MINOR__ <= 7)
-+#if __GLIBC__ == 2 && __GLIBC_MINOR__ >= 3
- /* See comment below for glibc 2.2. */
- #ifndef __USE_GNU
- #define __USE_GNU		/* to un-hide RTLD_NEXT */